Xiaomi Mi Router 4A Gigabit Edition Unstable

I installed this on my Mi 4A gigabit: https://gitlab.com/db260179/xiaomi-m4a/-/releases/v1.6-stable
Successfully made wifi range extender with relayd.

When I try to mess with firewall i cant save any changes. Weird. Uninstalled firewall. I also noticed sometimes i cant update/download any software packages, I must retry few times to get it working. Error reports no Internet but in connected whole time to Internet via Wifi client.

AP is working I can use it for Internet. After few minutes router randomly crashes and restarts.
How can i fix this issue and make it stable?

Why not using the official build?

1 Like

i flashed the latest official build linked by user above, same issue.
After turning off and on router wifi ap works , but lan connection seems dead, unindentified network- tried auto ip adress or manual assign no luck.

Have you tried resetting to factory defaults? Are there any errors shown on system logs?

I have set up another AP on 5gh separate radio on my device. Both 2.4 and 5Ghz AP are up. Im using 5GHz one and it seems stable. Weird.

I installed mine, all ok. LAN port fast ~ 9xxMbps, very good for the cost.
post your "network config" here.