Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Yes it worked and thank you.

Here is how i did managed to get this work:

  1. connected lan cable to pc and right port on my router, changed my ip address in pc settings to 192.168.0.2 and subnet to 255.255.255.0

  2. pressed reset button and pluged power to router. after holding 10 seconds, orange light starts blinking.

  3. opened BOOTP/DHCP SERVER and got the request but in DHCP type and not bootp.

  4. clicked on it and set an ip to it (192.168.0.3)

  5. opened TFTP application, seleced my network card with ip of 192.168.0.2, selected log viewer and saw test.bin request.

  6. clicked browse, selected my folder that contains test.bin which is my firmware.

  7. transfered into device. at this point, don't close and touch anything. wait like 10 minutes and then you will see your orange light changes color to blue. close apps and and change ip settings on your pc to DHCP and boom. its working. for better performance, restart your router once. just unplug/plug the router.

1 Like

this is an old version that works try it some package is included like luci.

http://www.mediafire.com/file/0qetz7rm8n9hr04/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin/file

1 Like

Thx did it work for you :slight_smile: ?

1 Like

yes sir .it worked for me

Thanks for helping me to install OpenWrt!

Although, I managed to brick my router after installing OpenWrt :smile:.

Since I'm on Linux, I wasn't able to use the tutorial for unbricking by @Albertcp, but I found this one using dnsmasq and it worked

3 Likes

i kept trying to flush the gigabit version from WIN & linux with no luck, i get always to brick it. Tomorrow i ll try to use a MAC OS VM just in case is an os issue. Opinions on that? Regards

I see in the image you uploaded that you did not check the SHA before installing the firmware. The first step would be to do that, to make sure the download is correct. Find the command you need to execute in the readme of https://github.com/acecilia/OpenWRTInvasion

1 Like

Thx acecilia i've done that and i reached same result over. The only idea that i have now is to use a MAC os to see if will make any difference. Really weird during last stage when is rebooting i lose connection, i do not get done mesg and router stays lit with yellow light. i leave it over night and check it later maybe is just taking more to deploy the firmware...
AND btw big thx to everyone who worked on this, amazing that made this thing work.

1 Like

flashing the snapshot on 5 Apr 2020 (new kernel) cause the device failed to reboot (system halted).. . anyone succeed installed the current snapshot after 5 Apr 2020?

1 Like

So good news i finally managed to install it. i used the image provided by @Zorro http://www.mediafire.com/file/0qetz7rm8n9hr04/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin/file and @acecilia method:

cd /tmp
curl -O https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin # Download firmware
./busybox sha256sum openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin # Verify the firmware checksum before flashing, very important to avoid bricking your device!
mtd -e OS1 -r write openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin OS1 # Install OpenWrt
1 Like

@Zorro, @Arianismmm, I bricked my router again testing some configurations in openwrt. As I was applying the method I posted I ran into the DHCP differences in protocol type you were saying. It doesn't alter the steps to take but I guess bootp/dhcp is using dhcp instead ob bootp.

I also realized that the type of "bricking" I experimented initially may be different from the "brickings" I'm experimenting now: the router system led (left one) was blinking at 3 seconds pace in yellow (when I got bootp) the time I got it bricked, the other times it was just static yellow (when I got the dhcp).

I was trying to edit my previous message but I can't manage to do it. Is there any limit (number of times or days old) regarding post edition in this forum?

On the other hand, I am experiencing issues trying to flash openwrt again. It might be something to do with what @frosp is pointing out:
when I managed to successfully install openwrt it was on the weekend (4th or 5th, I don't remember the snapshot day I used). As yesterday wanted to try to install another package I had to update to the last snapshop (6th) using sysupgrate. It bricked. I tried to flash it a few more times just in case I got a corrupted image (I've performed checksums then) but the result was the same. Today I tried to install today's snapshot (7th) but I'm facing the same issues.

I have not performed deepest test so I cannot tell it's because something is wrong in latest snapshots but it might be a possibility since some users are experiencing similar problems.

@AlecsJon, which snapshot version (day) did you used?

2 Likes

Hi @Albertcp i used
OpenWrt SNAPSHOT r12138-1e3bfbafd3 / LuCI Master git-20.064.26720-acef567

Of course i changed the URL in @acecilia 's method with the one for the above image. That image u can take it from http://www.mediafire.com/file/0qetz7rm8n9hr04/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin/file

2 Likes

I tried latest snapshot apr 7, also failed.

1 Like

Thanks @AlecsJon and @Zorro, I've tried your images and indeed they work.

I didn't remember the kernel version or luci version of the previous one that worked (the ones from the weekend) but I'd guess there were newer. But it's better this than nothing and it's actually quite nice that it already includes some packages, included luci.

So I suppose it's just a bug in recent snapshots. Something logical bearing in mind that this is a testing firmware. We will need to be testing then every now and then to see if they are bootable again.

Thanks!

2 Likes

About 11 days ago I managed to successfully install openwrt on the specific router with the expoit.

Today I wanted to download the last snapshot to upgrade. The router unfortunately became bricked but fortunately thanks to this post https://www.arednmesh.org/content/​how-unbrick-tp-link-node I managed to pass the original firmware in Chinese. Then I did the same procedure again, but while it shows that exploit is acceptable on the router, the router never starts. It stays stable with the orange light permanently on.

Any help is welcome

Hi, latest snapshots aren't usable. See previous posts. Try using an older version (someone posted a link to a valid image). From the changelogs, I see that Openwrt team is migrating mediatek platforms to kernel 5.4 so don't expect much stability from latest stuff at this time unfortunately :frowning:

My advice is to give them some time and meanwhile flash older images that others have tested as usable.

3 Likes

I think your method should use *.bin that more stable than Openwrt snapshot build. last snapshot may break router from reboot ,To do that you should upload *.bin to somewhere and curl -O *.bin to that source. Because its more safe for your method. User can update Openwrt later.

Guys, @acecilia has updated his exploit. We can now access file system dir using ftp. Just upload whatever bin we want to flash directly.

3 Likes

For us who returned to the Chinese rom (2,28,62) , nothing happens if we don't turn to 2.28.132. I try it 100 times.
I've searched everywhere to find it without result

E D I T

I finally succeeded by replacing the curl -O https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin with curl -O http: //medload16 .com / ucqhcldw0vag / 0qetz7rm8n9hr04 / openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin

1 Like

I have compare Wifi speed of OpenWrt vs Official ROM.
on Lan speed at 500/400
on Official ROM 500/300 (Dual-Band Mode)
on OpenWrt 220/300 (5G,2G same SSID)

Why download just half of official rom?
Did I forget some settings?