Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Hi @rubee,
just to clarify:

  1. Do I get you right you updated a Mi Router 4A Gigabit from
    Stock Firmware 2.X.Y to OpenWRT Snapshot by "just" renaming
    the OpenWRT into sysupgrade.bin or did you ...

  2. ... use Zorros manual how to do it, two post before yours ?

1 Like

it worked for me i successfully restored my backup.bin the process takes 10-15 minutes...
does the start_create_backup.bat makes a correct/complete backup of the nand?
yes, it will create a full backup from flash chip including your router mac address...

2 Likes

how to flash openwrt with the latest scripts :
1-download openwrt put it in "firmwares" folder
2-run 0.start_main.bat enter the password of your router
3-finally run" 5.start_write_OS.bat" choose the firmware you want to flash it and be patient process will take 7-10 minutes

2 Likes

what firmware is most stable?
zorro firmware from 28/04?

Thanks @Zorro,
excellent work. This is indeed easy enough to become a fully supported hardware on OpenWRT.org. Unfortunately they are working on Version 20.
Is there a stable Version 19.07 flying around for this Mi Router 4Gigabit with acceptable performance ?
I need one of my Routers to be flashed for a friend with something not "too experimental" :grinning:.

1 Like

@wimpie007 @makku71 kernel 4.14 is the most stable choose one :
1)https://anonfile.com/16y6d6x7of/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade_zip

2)https://anonfile.com/Xf2adfxaof/mir3g-v2_owrt_19.07.2_zip

3)https://anonfile.com/ld6dd9xao1/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade_bin

3 Likes
  1. seems to be kernel 4.14.171
  2. and 3) have the same name, but differten size...
    which is what?

Thanks!

1 Like

(1) and (2) are kernel 4.14.171 and (3) is kernel 4.14.167 difference between them are pre-installed packages if you want openvpn and wireguard install (1) if you need sqm qos and adblock install (3) if you need a light build with only luci install (2).

1 Like

Just renaming the openwrt build to sysupgrade.bin and the rest process is the same as zorro's guide @#525.This process worked flawlessly for me uptill now.Used firmware at this link:https://anonfile.com/LbueT2n8o4/openwrt-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade_bin.

Kernal 4.14.172 Working Great.

Please keep me updated if there's a more stable and robust performing build comes up.

For all.Thank You.

2 Likes

with new update you don't have to rename it to sysupgrade.bin you just put the .bin file in "firmwares" directory...

1 Like

@Zorro the updated R3GV2+Patches mediafire link doesnt work for me.When requested for downloading idm shows cannot download this file.Error 'Internal Server Error'

1 Like

mediafire link works for me but here is new update :
https://anonfile.com/X3B8e4xdo2/R3GV2_patches_21.04.2020_zip

Hi @Zorro,
have taken second option/Binary.
Deleted Russian Luci Files (not needed) and installed Material-Design.
Thats it. Works flawless and should do until we have Version 20.
Will also do some IPerfing later. Thanks

1 Like

IPerf3 Results in '--bidir' Mode are

  1. Ethernet-Based
    [ 5][TX-C] 0.00-30.01 sec 2.76 GBytes 789 Mbits/sec 0 sender
    [ 5][TX-C] 0.00-30.04 sec 2.76 GBytes 788 Mbits/sec receiver
    [ 7][RX-C] 0.00-30.01 sec 284 MBytes 79.3 Mbits/sec sender
    [ 7][RX-C] 0.00-30.04 sec 283 MBytes 79.0 Mbits/sec receiver

  2. WiFi 5GHz Optimal Link Speed 866,7MBit/s
    [ 5][TX-C] 0.00-10.01 sec 411 MBytes 345 Mbits/sec 0 sender
    [ 5][TX-C] 0.00-10.06 sec 411 MBytes 343 Mbits/sec receiver
    [ 7][RX-C] 0.00-10.01 sec 64.2 MBytes 53.8 Mbits/sec sender
    [ 7][RX-C] 0.00-10.06 sec 63.7 MBytes 53.1 Mbits/sec receiver

with Zorro's 2nd Link here.
No decrease/dipping to lower-link speed. :grinning:
That will do to let it out in the field until we have an OpenWRT V20 for this.
Thanks again to everybody.

3 Likes

I got a problem with my r3gv2.
I flash with april version of openwrt .bin posted were. I OpenWRTInvasion and ended ok but after reboot I got no boot on router. Then I restore with bootp/dhcp and Tftpserver to upload the original firmware.

were the Tftplog : Connection received from 192.168.1.3 on port 1833 [08/05 15:55:19.504]
Read request for file <test.bin>. Mode octet [08/05 15:55:19.504]
OACK: <timeout=3,> [08/05 15:55:19.504]
Using local port 49242 [08/05 15:55:19.504]
<test.bin>: sent 26114 blks, 13370296 bytes in 6 s. 0 blk resent [08/05 15:55:25.196]<
The router start to blink purple light faster and dont stop. If I disconect and conect again from power I dont have ethernet comunication. I have to press reset and power on to have to comunicate again with bootp/dhcp and Tftp but after flash test.bin the router start to flash purple again.
What I can do?

@makku71
from the zip file (2.), did you select
openwrt-19.07.2-ramips-mt7621-xiaomi_mir3g-v2-initramfs-kernel.bin
or
openwrt-19.07.2-ramips-mt7621-xiaomi_mir3g-v2-squashfs-sysupgrade.bin
in the firmware script 5.start_write_OS.bat?

1 Like

The xxx-sysupgrade.bin.
Did a full reset (press and hold Reset-Button until LED changes)
after complete boot, because I did not get a connection on first try.
MIght or might not be necessary. Don't know - just did it.
AND BE PATIENT. IT TAKES SOME TIME. DO NOT POWER OFF OR SO.

3 Likes

@Zorro do you also have a version with adblock?
or can i do an commandline upgrade (package install) afterworths?

1 Like

Number (3) has adblock you can't install it via CLI commands .

snapshots are built daily, and that sets time limits to installing new packages with opkg. Due to kernel version checksums, you can only install “kmod” kernel modules and other kernel version dependent modules from the exactly same snapshot build. So, a few hours after flashing the firmware you may not be able to install new modules with opkg any more (as the next snapshot has been built into the download repo and has different checksums).

but before you flash number (3) you can try with (2) and see if it's possible to install adblock or not .
be sure to update without saving the settings...

2 Likes

Hello guys and thank you @Zorro !!!

I bought this 4A gigabit router and it came with chinese firmware and also I was not able to get the WAN
running properly, it had and older version 2.28.18 so might have been some bug.

I flashed it with the latest EN 2.28.132 firmware you provided, plus added english and everything now works like a charm!

I would really like to try openwrt in near future (never had before), so will definitely try using your method, and possibly come back here with the result.

God bless these guys, they are geniuses.

3 Likes