Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Hi,After openwrt flash, luci cannot install error (I run the first opkg update) How can I install version 19.07.3 ?

They didn't fix yet the issue of WiFi extender function in rc3, it cuts beyond of my speed even though i have 200mbps plan but in Lan cable it runs with no issue and 100% efficient...I'm still sticking in my old build

1 Like

What speed did you have in the old and current version?

I submitted once here but, I think last month?
But i tried again
My old snapshot build
200 mbps down no packet loss

RC3
50 mbps 7% packet loss

I submitted a bug report last 25 days.I hope they fix this in official

Hai, same goes to me here...do we need Spi programming to solve this issue?
.
I've tried all the firmware provided, orange led only not turning to blue led as usual once debricked process done..please help...

Hello,
I just updated from db260179 19.07 build to 21.02 rc3 and it works ok except for the switch (the wan connection gets disconnected and reconnected every few hours) and i get this message on kernel log every time it happens :

[17965.105187] mt7530 mdio-bus:1f wan: Link is Down
[17968.177242] mt7530 mdio-bus:1f wan: Link is Up - 100Mbps/Full - flow control off

Can i fix that or is it a known issue? (WAN is connected with the modem via pppoe)

2 Likes

After flashing my R4A Gigabit with Byte-bite's 21.02.0 RC3, it turns out my router sometimes (once a week) reboots and factory resets itself. Openwrt backups are empty (0 bytes), thus I keep doing the whole router configuration (incuding enabling and setting up both radios) everytime.
Did anyone experience something similar? What can I do?

Im having a issue with 5gh, after a while the connection freezes and only after i turn wifi off and on on laptop it comes back

Anyone having this? Any idea?

It hasn't happened for me yet, but you should be able to manually export a backup of all of your settings from LuCI with the "Generate archive" button and restore that.

2021.07.15_20.52.49

If you set everything up and the backup-OpenWrt-2021-XX-XX.tar.gz you get is 0 bytes, something is very wrong with the installation itself. Try doing a clean unbrick with TinyPXE to miwifi_r4a_all_03233_3.0.24_INT.bin, get telnet access via the exploit and then install Byte-bite's openwrt-21.02.0-rc3-ramips-mt7621-xiaomi_mi-router-4a-gigabit-squashfs-sysupgrade.bin.

If it's still broken after that, I'm out of ideas. Hardware failure, maybe?

1 Like

Thank you for your help, I finally understood what was my mistake: I flashed the initramfs-kernel.bin firmware and forgot to flash the squashfs-sysupgrade.bin straight after...
Indeed somthing was very wrong with my installation but now everything works, my settings are persistent across reboots and I can backup my settings! :sunglasses:

Yeah, I have no idea what you'd even use the "kernel" images for.

I assumed "sysupgrade" files would be the minimal ones you'd need when updating OpenWRT from within itself (while the kernel ones are the more complete 'raw' images you use when flashing with a serial cable or whatever) but every guide I've seen so far recommends using -sysupgrade.bin for everything, be it updating, installing, flashing or unbricking. Some router models don't even have kernel releases, some have ones that are named "factory" or "rootfs0" instead, who knows. :man_shrugging:

2 Likes

A good solution:

unsolder the spi socket , remove the eeprom SPI, resolder the socket
you can use an EZP2020 programmer with SPI adapter :

ou CH341

Hi guys, I got my 4a Giga yesterday and flashed byte bits RC3. Everything is working fine, but I would like to install Openvpn and Wireguard. I got the message that the kernel is not compatible. Now my question is, does anyone has an image I can use with Openvpn and Wireguard? I don´t know how to compile a new image and I would prefer to have one which I can flash. Or does anyone have an other idea how I can install the applications? Thanks in advance!

Hi there,
There is no such an issue on official builds. Why don't you just flash them instead of compiling a new image?

21.02.0 RC3 for xiaomi mi router 4a gigabit
https://downloads.openwrt.org/releases/21.02.0-rc3/targets/ramips/mt7621/openwrt-21.02.0-rc3-ramips-mt7621-xiaomi_mi-router-4a-gigabit-squashfs-sysupgrade.bin

sha256sum:
5f5f96d3017bfab03cea6978af51fe3d2810e54c7e4d9fcd135354255da0afdc

ulpian

6 Likes

Hi There

the software package lists (/etc/opkg/distfeeds.conf) in byte's build still points to rc1 release,which has older version and cause them to be incompatible. you could update them to rc3 release list in Opkg configuration on luci

3 Likes

Is anyone here knows how to add custom hosts for adblock? I want to use Energized spark with only 8K hosts attached ,I don't like the Yoyo host it doesn't block some popups

Hi there,
There must be some text file that contains all adlists and their URLs on it. I guess you can edit default adblock lists with your favorite text editor.
I'm not saying that this is the most elegant way to do that but if it works I'm okay with it.

ulpian

1 Like

Thanks your solution also solved my problem :+1:
Now I can install mwan3

Hello,
I wanted to announce that 21.02.0 RC4 is here. Cheers!
https://downloads.openwrt.org/releases/21.02.0-rc4/

ulpian

2 Likes

Wow this is the first time for "RC4" and i thought they gonna release the official this month....but I'll check it if they fixed the WiFi bridge issue

1 Like