Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Trying to keep up on all the messages I saw that you were trying to download the system squashfs image from GitHub with curl GitHub... --output firmware.bin But just as a quick note when downloading things with curl always append a -L so that curl follows redirects. Without that your download will most likely fail. Also make sure that the time and day's right! If not the certificate of GitHub.com might not be valid (yet). :wink:


Anyone else having constant PPPoE disconnects with latest snapshots?

Every 2 minutes....

@araujorm i already installing your new release firmware, but when i want to change override MAC address, and old MAC address still exist... can,t change.... thanks for your attention

@junkieadi sorry not really sure why, maybe the hardware does not support it? or it's not implemented in 19.07? my build is just a small fork of 19.07.04 so it's not something I can fix, maybe try on more generic topics on the forum if no one here in this thread knows... or try a snapshot build...

1 Like

i got this!!

work for me....

1 Like

anyone guys having issues with R4A 100M for having a memory issue, if I left it running for around 10-12days, the router will just crash on its own with Luci telling Out of Ram if you try to open it on your web browser.

I think with 19.07.4 the RAM issue is mitigated (well kind of) at least, but still getting below that 5MB Free RAM but the services doesnt crash anymore so I can access luci and such after 10+days, but with one major issue, there's this "NETDEV WATCHDOG: eth0 (mtk_soc_eth)" issue making the router to hangup for a few seconds and kill the 2.4ghz wifi (will recover on its own if you give it some time) and this happens a couple times in a single day.

im only using R4A 100M as a Access Point, no extra things, but it seems its plagued with issue using OpenWRT. So either you choose 19.07.3 and just put a cronjob for scheduled reboot due to RAM issue or deal with 19.07.4 plagues with NETDEV WATCHDOG issue popping up all the time.

Does the following help?

im not really sure about it, can you link me for the firmware so I can try it out?

--force-depends is a bit of a nasty hack basically your ignoring all errors generated because your installing software that was designed for a different kernel version. I often suggest it for getting luci on openwrt for those who need a quick simple solution and I know it generally works but defiantly won't work for all software, and i normally recommend to people to then sysupgrade to a firmware with luci included (using luci) after for stability. Just to explain why you may have seen me suggest this in the past on here.

If your getting kernel errors when trying to install you should try a more current snapshot or build your own with the software you need included.

@zandatsu07 ...or if you plan to use a snapshot rather than custom build, then install all the packages you require on the same day the snapshot was released as this should avoid depedency mismatches. Remember to use "opkg update" prior to installing the packages.

1 Like

Why don't you just edit a backup image ,so the mac adresses are what you want them to be?

Flash it back and then OpenWrt will use these instead.
To be exact,they are in the Factory partition..

It shouldn't be needed. When he asked I thought he had already tried to do it using the official built in way, which is to use LuCI or edit the options files (he later stated he edited the option file and it worked). For the record, this should suffice, by editing the interface in LuCI and going to the advanced options:

If this way it doesn't work, then a bug in OpenWRT should be filled, since my build is based on the stable version and it is supposed to work.

1 Like

Yes,but i thought he wanted the mac address change to be permanent.

That's why i mentioned the editing of the backup file.

It's even possible to do it in OpenWrt itself,just needs the mtd-rw kernel module installed.

What is the current level of performance of Last OpenWRT version? (i mean in the term of WAN speed, Wi-Fi speed, it is working on gigabit speed, as i have a full 1 GBPS band).
I owned currently version 4A Gigabit on the latest firmware version 3.0.24, can i install latest version with acecilia exploit?

I put the question, I give the response.
Tried today last @araujorm build but it's really a pain, WAN speed limited to about 550-600 Mbps (stock was 920-930 Mbps), 5 GHz Wi-Fi not even started.
Sorry, but returned to stock 3.0.24, there's more work needed to make a better version.
LE: no offense, I appreciate hard work needed to make a stable version, but, from what I can see, now it something like an "alpha" stage.

What investigation and troubleshooting data did you capture during this testing?
5 GHz Wi-Fi works fine on @araujorm builds.
Have you considered also testing the OpenWrt Master Snapshot builds?

I have seen some hostapd error in logs, but unfortunately not saved any logs.
Maybe i should try OpenWrt Master Snapshot builds, but i'm too lazy to do it now.
Maybe tomorrow, we keep in touch.
LE: already tried latest snapshot, build have many problems, i have reinstalled @araujorm latest build and now working fine everything! Maybe first time i have a bad flash or corrupt file.
Thanks @araujorm and @acecilia keep up the good work!

1 Like

Good to hear...
There are some recommended WiFi tweaks that @hoddy has posted previously (somewhere in this thread and also on blog) which can help get a little extra performance from both WiFi bands.
With @araujorm build I also found disabling the AdBlock services helped reduce load on the router (if you are not looking to use that application)


Wi-Fi performance is also very good, no need any tweaks, anyway, thanks for suggestions.
I hope this version will be maintained.