Xiaomi Mi Router 3G - dead

Hello everyone. I installed the LEDE / OpenWrt firmware on the Xiaomi Mi Router 3G router. Everything went well and I could access the LuCI web interface by typing in the browser
Here, unfortunately, I did my own thing and I think I had a mess. The intention was to configure the router with a LAN-WAN connection so since the operator's modem has the address I changed the 3G IP to and I clicked on Save & Apply.
Now I can no longer, even if the router is connected to the PC, to access it to complete the configuration of the WAN and other settings. I tried to configure the LAN interface of windows 10 in all possible ways (dhcp enabled, disabled with fixed ip) but nothing. I'm not even sure that the router has saved the new IP since after clicking on Save & Apply had given a message that probably indicated some anomaly.
Can you tell me a way to solve the problem? Thanks

"failsafe" mode should get you back to a known condition and able to connect to the device, then "fix" the bothersome configuration.


1 Like

I tried the method "Wait for a flashing LED and press a button" but led became blu and blinking continuously so I can't reach the router with Putty.

  • What was this message?
  • Was it a warning that your settings reverted?
  • Did DHCP ever issue an IP to the Windows 10 machine?
  • If so, what was the DHCP server's IP address?

Sorry but I don't remember

I get:

Scheda Ethernet Ethernet 3:

Suffisso DNS specifico per connessione: lan
Indirizzo IPv6 . . . . . . . . . . . . . . . . . : fddb:c260:e842::fd0
Indirizzo IPv6 locale rispetto al collegamento . : fe80::7ce5:a180:a150:c9bc%8
Indirizzo IPv4. . . . . . . . . . . . :
Subnet mask . . . . . . . . . . . . . :
Gateway predefinito . . . . . . . . . :

and if I turn on wlan for this at the same time:

Scheda LAN wireless Wi-Fi:

Suffisso DNS specifico per connessione:
Indirizzo IPv6 locale rispetto al collegamento . : fe80::2114:7b8b:dd6:d4c8%3
Indirizzo IPv4. . . . . . . . . . . . :
Subnet mask . . . . . . . . . . . . . :
Gateway predefinito . . . . . . . . . :

Please use ipconfig /all in order to see:

  • "DHCP Enabled yes/no" and
  • "DHCP Server" values

Done but no results.
I thought about following unbrick workaround described here restoring original Xiaomi fw and then reinstalling OpenWRT

If there are no results, then your WiFi and wired are still configured for static IPs, you won't be able to determine the DHCP server with a static IP configured.

Why not try?

@maxb66: it looks like you are getting an IP address from your router. why not try to ssh (use putty since you're on windows) to connect to the router? once you're "in" you can try to clean up from there. But it might be less work to restore the original firmware and do a reinstall of openwrt :wink: depends on how confident you are with linux commands (if not at all, then just re-flash the firmware. it will be less frustrating).

1 Like

@ilyas I tried with Putty but putting this IP as host and Port 22 I don't get credential request

@maxb66 i'm not sure what you mean when you say "i don't get credential request"... are you connecting to the router at all? try ping'ing your router to make sure you can actually communicate with it.

from what i'm seeing, it looks like your router is giving out two different IP addresses? you could try connecting both through ethernet and wifi (from the same computer at the same time) and try ping'ing the router


(those are the two addresses which look like your router is/might be on)

then use putty to connect to both of those addresses (first one then the other)
you should say "yes" to accept unknown certificates and then login as "root" and using whatever password you already gave the system (possibly blank?)

if you can ping your router it's certainly not dead.

1 Like

No sorry the ip address come from a different router not from Xiaomi.
So the Xiaomi connected by lan to pc give back as gateway.
If I set Putty with this ip I get from him the message "Network error: Connection refused"
Thanks for your support.

i really think you're better off just trying to reflash :wink:

Probably starting all over again with stock firmware isn't needed.

1 connect by cable
2 on PC use DHCP to get IP configuration
3 when no IP config provided, set IP config of PC to static
4 If you can ping try to connect in webbrowser to
5 when connected, correct settings (for SSH, those are under System->Administration).

Possibly the static LAN address has previously been set to When the steps above do not work, you could try repeat those, but using 192168.2. in stead of 192.168.1.

Molto auguri

I can not debrick my router by usb.
when I want to choose option 4 (Enter boot command line interface)
nothing happens that ca reboot incessantly
can we reflash in another way?
thank you