Xiaomi BE3600 network config setting for VLAN ID

Hi everyone. My friend bough Xiaomi BE3600 router with dual switch (we guess). Unlike R7800, this model's switch configuration is quite different. I know this is not officially supported model but since it's OpenWRT based, I hope someone can help.

Our ISP provider uses VLAN ID 35. We don't know where to put it.

Original /etc/config/network file is here below


config device 'eth0_dev'
	option name 'eth0'

config device 'eth1_dev'
	option ipv6 '1'
	option name 'eth1'

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch 'switch0'
	option name 'switch0'

config switch 'switch1'
	option name 'switch1'
	option enable_vlan '1'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.31.1'
	option netmask '255.255.255.0'
	option multicast_querier '0'
	option igmp_snooping '0'
	option ip6assign '64'
	option macaddr '50:88:11:b2:ed:d8'
	option ifname 'eth0.2 eth0.3 eth1'

config alias 'lan_ipv6_alias'
	option interface 'lan'
	option proto 'static'
	option ip6addr 'fd00:6969:6969::1'

config interface
	option ifname 'eth0'
	option keepup '1'

config interface 'eth1'
	option ifname 'eth1'

config interface 'wan_2'
	option disabled '1'
	option proto 'dhcp'
	option ipv6 '0'
	option wantype 'eth'
	option macaddr '50:88:11:b2:ed:d9'

config interface 'miot'
	option ifname 'wl13'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.32.1'
	option netmask '255.255.255.0'

config switch_vlan 'vlan1'
	option device 'switch1'
	option ports '3 5t'
	option vlan '1'
	option vid '1'

config interface 'eth0_1'
	option ifname 'eth0.1'

config switch_vlan 'vlan2'
	option device 'switch1'
	option ports '2 5t'
	option vlan '2'
	option vid '2'

config interface 'eth0_2'
	option ifname 'eth0.2'

config switch_vlan 'vlan3'
	option device 'switch1'
	option ports '1 5t'
	option vlan '3'
	option vid '3'

config interface 'eth0_3'
	option ifname 'eth0.3'

config interface 'wan'
	option proto 'pppoe'
	list dns '9.9.9.10'
	list dns '149.112.112.10'
	option mtu '1500'
	option ipv6 '1'
	option peerdns '0'
	option wantype 'eth'
	option username '******'
	option special '1'
	option mru '1480'
	option macaddr 'cc:d8:43:1c:bb:76'
	option password '*******'
	option ifname 'eth0.1'


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

Read device specifications whem buying - it does not claim to support dot1q standard.

1 Like

My friend bought it. I appreciate the explanation regarding the termination. Thus, if it is even possible, he will have to wait for someone to create an official OpenWRT build for it?

You can try, but somewhat later when wifi7 is in mainline kernel and hostapd

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.