Xiaomi - AX3600

Following steps from here https://openwrt.org/toh/xiaomi/ax3600

I roll back to roll back to the Chinese OEM firmware version 1.0.17
Then Obtain SSH Access via the JavaScript method by logging into the router page 192.168.31.1 then press 12 go to console and paste the code from the above link - hit enter then type in a password.

I copy and paste all the commands into the SSH replacing the name of the file to the new one "openwrt-23.05.3-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi" all seems to work fine up to 6 after the reboot - router light is blue but I can't see the ip address of the router, when I try "192.168.31.1", "192.168.1.1", "192.168.0.1" and when I type these addresses into chrome it doesn't load.

Install the Firmware steps 1-5
I follow all steps I SSH into router - I copy the Firmware OpenWrt Install URL factory images from the above to the router tmp folder
I first cd to the folder where the ubi file is saved then run

scp openwrt-23.05.3-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi root@192.168.31.1:/tmp

nvram get flag_boot_rootfs

cat /proc/mtd

I've had to use TFTP recovery 2 times and the first time the router booted from 0 and the second after recovery it booted from 1 I used the relevant code for that by copying and pasting.

ubiformat /dev/mtd13 -y -f /tmp/oopenwrt-23.05.3-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi -s 2048 -O 2048 && nvram set flag_boot_rootfs=1 && nvram set flag_last_success=1 && nvram commit

After step 6
Here is where I run into issues - In cmd I try ipconfig and there is no address for default gateway. I try both the WAN and LAN1 ports, try restarting both PC and Router nothing seems to make a difference.

Finally I do the TFTP recovery
I was having trouble getting this working following the windows instructions for anyone else having issues make sure to turn of antivirus and windows firewall and follow the settings on the above url and everything should work to get the OEM firmware back to the router.

I'm not sure what I'm doing wrong. I do have Linux on a VM, I wanted to try doing it via the VM will that cause any problems?

per default the openwrt has 192.168.1.1 as default address.
i have two ax3600 running with 23.5.3

I did try 192.168.1.1 doesn't load anything. Should it also not show as the default gateway when I run ipconfig? when I run ipconfig the default gateway is blank.

Are you using a cable to connect between the router and computer?

Did you try rebooting your laptop after step 6?

The other option would be in Windows settings change the IP address from DHCP to static.
IP address 192.168.1.2
Subnet mask: 255.255.255.0
Gateway: 192.168.1.1
Preferred DNS: 192.168.1.1

If that works then you could configure the router and change back to DHCP.

Hi mathew thanks for all the help along the way.

I am using router connected via ethernet cable, I had setup this

IP as static to 192.168.31.100 , mask 255.255.255.0

for the recover do you think that is the issue?

I'm almost at the point of just buying a new router, kind of annoying.

So I tried doing it using my spare computer did exactly the same thing didn't try changing the the addresses and it just worked? Not sure what was going on with my other pc.

Just wanted to double check I correctly installed the .bin file it did say commencing upgrade. closing all shell sessions. but it was followed by command failed: Connection failed.

{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi AX3600",
        "board_name": "xiaomi,ax3600",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ipq807x/generic",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}

Also my speed is a lot slower than it was before i was getting around 900mbps now it's only around 250mbps


You will need to play with Traffic Steering and Offloading to get better speeds, but it will never be like the NSS accelerated QSDK builds of the stock firmware.

IMHO, that's not even the worst part. Looking at the spec sheet, one would assume the AX3600 is quite a few notches ahead of the AX3000T – quad-core vs. dual-core, professional SoC vs. lower-cost alternative, etc. In reality, my AX3000T consistently outperforms my AX3600 APs, so much so that I've bought new AX3000Ts to replace my existing AX3600s.

The most noticeable difference is in wireless latency (i.e., RTT). The AX3000T can deliver sub-1ms RTT in the right conditions, while (in my environment) the AX3600 struggles to get below 3ms and occasionally has massive spikes.

Credit where credit is due: Mediatek delivered proper Linux support so that we can enjoy their devices in OpenWRT. In turn, Qualcomm treated Linux support like an afterthought (still better than nothing, I know). Anything that doesn't go through their proprietary NSS accelerated path gets "second-class citizen" treatment and is easily outclassed even by inferior hardware with proper Linux support. (sorry for the rant :frowning:).

1 Like

Thanks that's a bit annoying. Now that I've got OpenWRT on my router can I install https://github.com/AgustinLorenzo/openwrt/releases via the system upgrade option?

Should be a simple matter of issuing sysupgrade -n or deselecting the "keep configurations" while sysupgrading via luci.

The only thing to be aware is that very old builds have a different (and incompatible) partition layout. Assuming you are flashing images based on recent OpenWRT codebase, you'll be fine simply sysupgrading images.

It makes a great AP though :slight_smile: