Xiaomi AX3600 Debrick tftp fail

Hi all,
I bricked my Xiaomi AX3600 recently and tried to use UART for recovery but could not reach out to the TFTP Server. I tested TFTP Server with another client, and it works fine. I tried on Windows 10, tftp64 and on Debian. Both do not work for Xiaomi AX3600. Anything I missed out?
But uboot shows the Ethernet port is in UP state.


Firewall on the tftpd host being up ?

I disabled Windows firewall. For Debian allowed tftp port (69) in iptables. But I using other device having Ubuntu for tftp client it works so I think i won’t be the firewall issue

Yeah, you wrote it, stupid question.

And your tftpd host have the same IP as the one in your screen shots ?

Yes. Although I changed to others IP Address it not work too (of course I change the uboot env). Since other device can successfully get file from tftp server so I think sth I miss out at Xiaomi AX3600.

When using tftp recovery (other routers, didn't need to recover my ax3600 yet), I tend to run wireshark on the system providing the tftpd - this allows me to see what happens on the wire (does the router issue tftp request, are the IP addresses as expected, the expected file names, does the transfer go through). While this obviously won't help with anything, it can provide hints for further debugging if something doesn't work.

...plus putting an unmanaged switch between to-be-recovered router and the system providing the tftpd, to avoid the link-down/ deconfigure event.

I'm asking since the wiki page for the 3600 says uboot's supposed to request an IP from the DHCP.
If it does, then perhaps it not using the IP it's printing on the console.

Thanks I will give a try for wireshark and the unmanaged switch later on.

That means DHCP service need to be host at tftp server side? Cause I tried to connect other router, the log just shown the port that connected with AX3600 is UP. But didn’t assign any IP Address… (PS. I just try out any method not sure this works or not :sweat_smile:)

It needs to be on the same LAN, and probably same host.

  • The router boots and asks for an IP address on the LAN ports via DHCP

  • The TFTP server assigns an IP address to the router

  • The router then connects to the TFTP server (where your DHCP server listen, e.g.: and tries to download a file named with the IP address given by the DHCP server converted to hexadecimal.

From https://openwrt.org/toh/xiaomi/ax3600#tftp_recovery
The IP above is confusing, since it's matching the one in your screen shot...
That can't be random.

I try on wireshark here is the logs... DHCP Server is keep asking who is but does not get any reply from AX3600? Does this mean having issue the connection between them?

Here is some of the TFTP logs, I using OneDrive for better view instead of plain text

Tried... there does not have any DHCP lease from TFTP64 application