Xiaomi ax3600 bricked

Gives what?

It set the ip address automatically to 192.168.31.100

detect button press, continue check 5 secs
detect button pressed 5 secs !
confirm to launch xq_upgrade !
cmd=dhcp

Net: MAC0 addr:88:c3:97:cc:59:6d
PHY ID1: 0x4d
PHY ID2: 0xd0b1
EDMA ver 1 hw init
Num rings - TxDesc:1 (0-0) TxCmpl:1 (7-7)
RxDesc:1 (15-15) RxFill:1 (7-7)
ipq807x_edma_alloc_rings: successfull
ipq807x_edma_setup_ring_resources: successfull
ipq807x_edma_configure_rings: successfull
ipq807x_edma_hw_init: successfull
board_eth_init: ipq807x_edma_init successed
eth0
ipq807x_eth_halt: done
eth0 PHY0 Down Speed :10 Half duplex
eth0 PHY1 up Speed :10 Full duplex
eth0 PHY2 Down Speed :10 Half duplex
eth0 PHY3 Down Speed :1000 Full duplex
eth0 PHY4 Down Speed :10 Half duplex
eth0 PHY5 Down Speed :10 Half duplex
ipq807x_eth_init: done
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9
BOOTP broadcast 10
BOOTP broadcast 11
BOOTP broadcast 12
BOOTP broadcast 13
BOOTP broadcast 14
BOOTP broadcast 15

You are using windows or Linux to repair?

Windows 10

Hello everyone, this is my first message in the community, first, thanks you guys for all of your work!

@bouyhy1989, have you recovered your router?? You had almost done, check this if you didn't: https://forum.openwrt.org/t/tuto-openwrt-unofficial-redmi-ax6/111340#unbricking-the-ax6-with-a-windows-pc-and-no-uart-access-6.

My problem is different, I have an Redmi AX6 which, after one or two system upgrades with the stock firmwares or after an reset with the rear button of the device it got bricked.

So, I only have the TFTP recovery built-in option. I have serial output.
The u-boot looks fine but the problem is that the ethernet interfaces looks that they doesn´t work properly.

An image worth more that my no-native English words

And wireshark capture.

I had to change advanced options on Ethernet interface on windows PC, fixing the "Speed and duplex" to 10MB Half or full duplex both works and I can see the DHCP requests from router on the windows PC with Xiaomi recovery TFTP running on it. But the AX6 - AX3600 doesn´t catch the IP offered to him and process doesn't continue.

Any idea? Thanks anyway.
P.D.: I've read all of the forum about these subjects before write this message. Excuse me for my English mistakes.

Did you plugged the Ethernet cable on a LAN port of the AX6 (I made that mistake before)?

Yes, I did it. You can see in the picture "eth0 PHY2 is UP 10MB Full Duplex" which is the first LAN port. I tried all ports including WAN.

10MB Full Duplex is strange to me :thinking:
When I was trying to unbrick mine I was getting eth0 PHY2 up Speed :1000 Full duplex...

If the setting for "Speed and Duplex" keep in dafault "Auto Negotation" the link goes down quickly and I can't see the DHCP Discover outgoing packets from the router.

The only progress I got was that, changing that advanced setting on windows PC to 10MB. Al least, I can see DHCP Discover requests.

Personaly when plugged from LAN of AX6 to my computer with no special settings I don't remember receiving DHCP requests :thinking: the only thing I got was that

eth0 PHY2 up Speed :1000 Full duplex

In the serial output and that was enought to trigger the MiWifiRepairTool.

Check your tftp.log in MiWifiRepair folder and you will see the DHCP protocol trace before TFTP transfer.
Something is different in this case and I don't know what could be. I tried all of the success procedures that I saw in this and other forums without success.

The only line I was getting was complex DNS request: ignored. I din't have the file anymore (I was using my sister's computer which is now +100km away) + I think you'll understand that I on't really want to reset my router again ^^

People, I have a question: If the serial input is disabled, ¿How is possible rebooting the U-boot TFTP recovery with the keystroke "Ctrl+c" ??

Its not disabled, just ignored by U-boot

The same happens to me.. I'm unable to transfer the image to the router

the problem started when I had openwrt and I lost 2,4 and 5 Ghz interfaces (ath11k) only the iot remains..

I tried to install the original firmware and it reboots every time:
Coundn't get reading for the sensor x is 0x0020***** an reboots at 5 seconds... a full bootloop and at the same i can't use tftp... I'm completely lost!

Up I think is a hardware problem

Can someone one help me please!
Im trying to unbrick my device with serial port but i cant stop autoboot!

Is anything i can do?

Can you confirm that you can reset the tftp recovery process with "ctrl+c" keystroke?

No i can't reet u-boot . I can't type nothing with keystroke!
My ax3600 is garbage now!