Xiaomi ax3200 slow wifi speed

Hi there, I am new to OpenWrt!
I managed to set up Xiaomi ax3200 as access point with 3 SSIDs for my VLANs:

  • main 5GHz
  • IoT 2,4GHz
  • Guest 2,4GHz

Everything is working fine, except the Wi-Fi speed. Network->Wireless->associated stations it shows over 1Gbit/s speed connection, but when I run speed test by ookla it shows me maximum of 300Mbit/s. Once I connect directly to ax3200 by cable, I get maximum ISP speed, which is 600Mbit/s.
So my question is: Is it possible to get speeds around 600MBit/s over 5GHz wifi on my device? I also followed some similar topics, but none of them were helpful.
I tried to change Wi-Fi channel, set country code to enable software offloading (even I knew it won't help, because it is just an AP, not a router, which is in my case opnsense) and enabling WMM mode.

Good start would be to set proper country code and never change it.

Thanks for your respond!
Unfortunately I’be already done that
Do you have any other suggestion?

enabling WMM

Please clean all excessive settings you added from config files by resetting to factory.
WMM is not meant to be disabled for last decade.

Can you post waveform test from wired and all radios (2.4GHz has to be set to 20MHz for reasonable speed and 5GHz + set correct country code for 80MHz), like make a test AP.

If wifi says gigabit it is gigabit total for your uploads, downloads, and all people in same wifi channel 50 meters around.

Next CPU load test:
install htop and F2 Setup - disable hide kernel threads and enable detail cpu
Then make some screenshots while running test at fast.com set to 30 30 300 300. if you do not observe much higher CPU usage over wifi just make one screenshot from casual moment while testing of CPU bars down to like threads that take CPU time while testing.

Thank you for your help!

Unfortunately, I cannot go back to factory settings, because my Wi-Fi is in use by other house members that goes crazy every time I do sth with network...

Can you post waveform test from wired and all radios
Main (5GHz)
https://www.waveform.com/tools/bufferbloat?test-id=d28fa5ef-c78a-45ea-9728-109f8c783be3

IoT (2.4GHz)

Guest (2.4GHz)

Wired (connected to another port in AP):

Wired (connected directly to port in ISP all-in-one router):

Tests were done on MacBook Pro 16" 2019, which is capable of more than 600Mbit/s wifi connection, which I tested on another wifi.

My network looks like this:
ISP->opnsense on proxmox->mikrotik routerboard as a switch->openwrt AP
Unfortunately, my ISP doesn't let me bridge their router, so I'm behind double NAT...

install htop and F2 Setup - disable hide kernel threads and enable detail cpu

I managed to install htop, but cannot find package named F2 Setup. Also, where can I disable/enable options, you mentioned?

So it looks like your laptops ac netcard has only one 2.4ghz antenna
Please set 5GHz radio with proper country code and auto-select channel, 36 might be crowded.

I included 5GHz radio tests in quote :sweat_smile:
Here it is:
Main (5GHz)

5GHz is set with proper country code and auto-select channel is enabled. I've also tried with different channels with no success (I've checked which are least crowded)

Find other client for test.

I've also tried with iPhone 15 pro and iPhone X and got the same results. I've also tried connecting my MacBook Pro to my friend's WiFi and managed to get 600Mbit/s and that was on their ISP router...

Post /etc/config/wireless hiding keys and mac addresses, renaming different access point names as one two three etc , i find your wmm statement very culpable

Sure, here is /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path ''
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option country 'PL'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '1'
        option encryption 'sae-mixed'
        option key 'securekey'
        option network 'Main'

config wifi-device 'radio1'
        option type 'mac80211'
        option path ''
        option channel '13'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'PL'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '2'
        option encryption 'sae-mixed'
        option key 'securekey'
        option network 'IoT'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid '3'
        option encryption 'sae-mixed'
        option key 'securekey'
        option network 'Guest'

Management frame protection 11w should be 1 optional or 2 required for sae-mixed mode, I think it is so by default.
Settings seem correct: