Xiaomi 4a gigabit edition bricked - not flashing

I followed these instructions to get the original firmware back again.

The router is connected by ethernet cable. I get the following report from the software downloaded here.

13:54:18 DHCPc:discovering for another DHCPd on LAN
13:54:18 ROOT=C:\Users\simon\Downloads\TinyPXE4AINT\TinyPXE\
13:54:18 DHCPd started...
13:54:18 TFPTd started...
13:54:21 DHCPd:DISCOVER received, MAC:00-00-AA-BB-CC-DD, XID:7A1B51A1
13:54:21 DHCPd:OFFER sent, IP:, XID:7A1B51A1
13:54:21 DHCPd:REQUEST received, MAC:00-00-AA-BB-CC-DD, XID:7A1B51A1
13:54:21 DHCPd:ACK sent, IP:, XID:7A1B51A1
13:54:21 TFTPd:DoReadFile:test.bin B:0 T:0
13:54:23 DHCPc:another DHCPd detected on your LAN @

It looks to me as in the video besides the last line, but I think that does not matter. Waited 20 min and the lights are still flashing red. Also after restart, box is not generating any wifi access point where I could connect to.

I also tried to follow this guide, but I cannot find a possibility to download BootP-DHCP Server 2.3

@micky0867: You gave some explanations here

Can you please elaborate a bit on "Easiest way is to use a Linux PC with bootp in foreground mode and a tftp-server for this procedure."

@Albertcp: I cannot find the software Bootp/dhcp server that you mentioned here. Do you have another source or have it available by yourself? Many thanks!

It almost looks like it is working, but you will have to rename the factory firmware file to what the router requests, in this case test.bin, and store it in the TFTP server directory. Does the TFTP server show file transfer was completed?

I managed to flash it correctly. The problem was that in this dialog I had to enable private networks. It was not done in the video and worked for him, but not for me.

I tried to install openWRT again, but failed. How do I find out which firmware I have installed? It seeems crucial reading the github page https://github.com/acecilia/OpenWRTInvasion

I think I have the 2.28.62 as the bin that was uploaded is holding it in the file:

HDR1?Ì .?7?   0   t                          ?º  ÿÿÿÿ  ÿÿ  xiaoqiang_version               config core 'version'
	# ROM ver
	option ROM '2.28.62'
	# channel
	option CHANNEL 'release'
	# hardware platform R1AC or R1N etc.
	option HARDWARE 'R4A'
	# CFE ver
	option UBOOT '1.0.2'
	# Linux Kernel ver
	option LINUX '0.0.1'
	# RAMFS ver
	option RAMFS '0.0.1'
	option SQAFS '0.0.1'
	# ROOTFS ver
	option ROOTFS '0.0.1'
	#build time
	option BUILDTIME 'Fri, 28 Jun 2019 10:18:46 +0000'
	#build timestamp
	option BUILDTS '1561717126'
	#build git tag
	option GTAG 'commit b221a96d2a53f5769fe6aa5165e2a082418a3169'
   ?º      Ì    firmware.bin                    'V??&ð]ìð mÀ?  ??0?à??ÞMIPS OpenWrt Linux-3.10.14

The user @ksc91u claimed it is working with the firmware here, and that you have to be connected by LAN cable to the router to access openWRT. I entered the IP in the browser, but could not connect.

Which version exactly have you flashed?

Hi, everyone!
I am new for OpenWrt. I think I bricked my xiaomi R4A gigabit Version2 device.
I will need the followings? Could anyone please help directions to obtain those files?

  1. Xiaomi R4A Gigabit V2 (R4AGV2) factory firmware 2.30.20 bin file?
  2. Bootp/tftp-server BootP-DHCP Server ? (this guide)

Please help for directions !
Thank you so much!

I have successfully debricked my R4AV2 device using TinyPXE4A flashing 2.30.25.bin
(NOTE: MiWifi Repair tool did NOT work)
(NOTE: Bin File Earlier than 2.30.20 WON"T work for V2)