Xbox 360 cannot take IP from LEDE

I have just installed LEDE on my TL-WR1043ND V3 and i can say is WOW, is running at super-speed. This firmware is amazing, congratz to all contributors to this amazing firmware.
I have a problem to connect my Xbox 360 to router, i coming from DD-WRT where i have same problem. My console cannot take an IP form LEDE, even i set STATIC or auto DHCP.
IP which appear on the console is something like this:
From what i seen before in DD-WRT, when i disable Use DNSMASQ for DHCP, console take correct IP from router. So, DNSMASQ cannot comunicate with Xbox 360.
I cannot find a solution to make my console working with DNSMASQ.
Please help if somebody know how to resolve this problem, because i don't want to return to stock firmare (there, console is working).

System Log:
Thu Nov 23 21:09:01 2017 dnsmasq-dhcp[3304]: DHCPDISCOVER(br-lan) 30...............
Thu Nov 23 21:09:01 2017 dnsmasq-dhcp[3304]: DHCPOFFER(br-lan) 30................

This two lines repeated 10 times in the log.

If you disable DNSMASQ, the XBOX cannot obtain an IP from the router, because DNSMASQ is the piece of software that handles IP addresses to devices... perhaps there is some other device in your network acting as a DHCP server?

I don't have another router in my network, is the only one. In DD-WRT, disabling DNSMASQ will enable default DHCP server, which will connect to the Xbox 360. This option not exist from what i see in LEDE. There is another way to make comunication between dnsmasq and Xbox 360?

You need to set up the static IP address on the Xbox as well as in LEDE...

I have already set that, i was write this in my topic. Static or auto , still not working.

Recheck your configuration on both sides.

Believe me, i have rechecked many time. :pensive: I have computer skills, i know all settings in the console, all settings tried, no success. Console working with stock firmware, connected to Xbox live.
In any custom firmware, will not even take ip from router.

Just curious, did you select a static IP address that is outside of the DHCP pool range?

Example - your pool is to

Static IP of or will not conflict.

Never had an issue with Gargoyle, DD-WRT, OpenWRT, and LEDE using this approach.

As one word says, an image makes as many as 100 words. :wink:


As you can see, console appear on the associated stations with the correct IP, but on the DHCP leases list, not appear. In the network interface of the console, IP is

Per the Xbox setup link posted above, what happens when you set up the static IP/subnet/gateway...and have the DNS settings on automatic on the Xbox...and then select Test Xbox LIVE Connection ?

What happens if you assign a static IP outside the range of your pool (100-150), such as .99 or .151?

Try a static IP outside the pool range, and see if it makes a difference...

On the router or console?
On the router i set to static .151, same problem...

It needs to be set to .151 on both sides.

Still not working. Restarted router, restarted console...
It really piss me off this problem.

You might read through this article on the Xbox Live forum on opening NAT...

Failing that, you might consider replacing dnsmasq with dhcpd and bind...

Opening NAT is not a problem, i already configured that.
I know from DD-WRT that disable DNSMASQ as DHCP and as a NAT server will work. I already tried that. Not 100% , but in 90 % of cases when i start the console.
I think i must disable DNSMASQ in LEDE and do what you say, but now it's too late, maybe tomorrow i will try that.
Thanks for suggestions.
PS: I think this type of console is very problematic...this is my opinion. I read somewhere that is a list of routers accepted by Xbox 360.

You're connecting via Wi-Fi, maybe it's your wireless configuration? Not sure if Xbox 360 being so old has a B, G or N adapter in it. Maybe make sure all legacy modes are enabled on your router. Are your other wireless devices working correctly?

Also, I noticed you have a static IP but want your DNS servers assigned automatically? That may be conflicting. Try setting on your Xbox, the Primary DNS server to your router IP ( and leave Secondary '', or try setting on your Xbox, Primary to '' and Secondary to '' (Google's Public DNS Servers). Did you change your router from to by the way? I know stock uses, but default LEDE uses

Xbox 360 have wireless N connection , as you can see in the first picture posted from console by me.
All other devices working fine.
I don't have console set on static IP, i have set static IP only as suggestion of @jwoods to test some configurations.
Console is on automatic, only router is set to static IP.
I have changed default IP of the LEDE to, but this cannot affect connection of the Xbox 360.

@jwoods: today i have noticed that console have connected to Xbox live. In the present, all settings are initially made by me, console set on auto-ip, router set to static release ip to console.
Strange...but if i power-off and then power-on the console, right after started, will not connect to Xbox live, but after 5 minutes form the start, will connect.
Very strange, isn't it? :face_with_raised_eyebrow: