X86 stuck in booting when boots after poweroff

It is really upsetting. My router(x86 d2550) works fine as long as it boots successfully, but it always stucks in "booting openwrt" when I cut power before sleep and boot it in the next morning, and I have to long press the power button to shutdown and reboot it.
And I find out the issue always comes up with long time power loss even after "poweroff" performed, but a short-term power outage won't cause the issue, it just reboot twice("kernel panic - not syncing: fatal exception" then reboot).
I recompiled and reinstall the firmware, tried ext4 and squashfs, nothing works.
Yes, leave it on and everything works fine, but it is really upsetting.
Please help if you have any advice! Thx

How do you do the shutdown in the evening?

If the network card(s) are plugged in, rather than on the motherboard, I'd try unplugging them. May help you figure out it is to do with behaviour there.

Also look at BIOS power management options to see if any of them make a difference.

Thanks for reply, I have already tried what you say, but unfortunately it didn't work.I've tried all kinds of ways to shutdown, which didn't make any difference :frowning:

I would try a different disk, or install Ubuntu on the same disk to verify if the same problem occurs, in case another is unavailable.


good idea! Will try, thanks!

Check the bios boot disk priority - make your openWRT drive 1st to boot.

Check the bios battery: 7-8 years old = replace, (d2550 released 2012).

Bandaid solution - never turn it off - just suspend or sleep mode? My x131 i3 only uses 0.6W measured in sleep mode -ie. its not wasting power.


Last resort:

Reseat the drive.

Update BIOS? Maybe brick it? Do you have a back up router?

1 Like

Thanks. I'm a little suspicious of the bios. The battery is good, just checked, the priority is good.
The weirdest thing is that my router can't boot from a usb flash disk installed linux(ubuntu or openwrt), however, it can boot from the flash disk installed winPE. I can guarantee that the USB flash drive is good,it boots successfully on my PC.

Flash drives can be funny things. Some can be marked as removable disks, which allows them to be treated like an SSD / HDD caddy device to boot things like Windows To Go. Others can't. Some get confused if "forced" into one mode or another by a hacker. Some boot chains also get confused. In my experience :roll_eyes:...

if you have one available I'd try it on a disk caddy.

1 Like

Yes, it makes me confused now. And I don't have a disk caddy unfortunately.
Maybe I can install the disk into my PC.

1 Like

Seems like the issue is between OpenWrt and the drive. Kernel panic -not syncing means that the BIOS loaded the GRUB bootloader from the drive and the bootloader loaded the kernel from the drive but then the kernel fails to find the root filesystem (on the same drive).

The "booting OpenWrt" message means that the BIOS has read from the drive and loaded/executed GRUB2 bootloader.

I would try to boot OpenWrt from another interface, so USB or something else.

seems like an industrial board/PC. They love disabling stuff they think is not needed, and this causes so much grief to end users.

Do you have a page about USB options in the BIOS? Does it allow you to set the USB device you plug in "as hard drive" or at least not show as "removable drive"? Then you reboot and it should show up in the "hard drive" list in the BIOS boot page.

On what disk is OpenWrt installed when it actually works?

Can you post the board name/model or the web page where you bought it (aliexpress/ebay/whatever)?


Thank you so much for your expert reply, I really appreciate it.

Yes, at present, I'm pretty sure that the BIOS caused this problem. Like what you said, the kernel can't find the files on the disk, so I simply changed the boot priority, put the SATA partition boot first, the uefi came last, and magically my router boot successfully for the first time after a few-hours power off. But,the funny thing is that there is no VGA signals after boot :sweat_smile:, everything except this works fine. Although I think I can live with that, any ideas for the lost of VGA signal?

I have no idea, probably bugs in the bios that initialize the VGA wrong.
I have worked on similar industrial boards (same processor or generation) in a batch of old industrial touch panel PCs and if I touched VGA options, any option, the VGA broke hard and the screen remained black until I reset the bios.
I'm blaming that on the fact that the graphics in this gen of processors is not really from Intel but from Imagination Technologies, Intel has licensed their PowerVR GPU, and had to use their own blob drivers and firmware. For example there are no drivers for 64bit operating systems for this GPU.

You can try the UEFI version of OpenWrt and see if it's better on that board.
UEFI should be a more "native" way to boot for that board (as its firmware is UEFI and can boot in legacy mode, now you boot in legacy mode) so maybe it's better for the VGA.

1 Like

It's Ok, I can live with that. Thanks again, I really learned a lot. :grinning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.