X86 - make menuconfig @ macOS - ncurses not found

Related to the question asked in this topic, I ran into that same issue.

With target x86/64, after the first compile, make menuconfig would fail saying ncurses could not be found.
The author above chose to monkey-patch the mconf-cfg.sh. But I found it strange that from the same revision the build tree for ath79 does not have this problem.

I found that (this is on MacOs Monterey, M1) comparing the staging_dir/host/bin folders of the 2 trees, shows the reason. In the ath79 tree, there are about 20 soft-links to diverse tools in my homebrew folder, but in the x86 tree there are much more real files, including pkg-config a script pointing to pkg-config.real. This pkg-config is the one the Makefile finds and runs after the first build and it is this one that does not find ncurses.
I tried by simply renaming it and retrying... make menuconfig works.

I know it's not officially supported, but I assume I am not the only one trying it. And if they run into this problem, at least there is a work-around.
I cannot even build for ath79 as mkimage is broken on M1.