X86 installation and ZTE MF286D module

hi guys

i am italian and my english is not good but google translate helps me. :stuck_out_tongue_winking_eye:
I read that openwrt now supports ZTE MF286D, so I wanted to do an experiment.
I installed on a virtual machine OpenWRT 21.02.3 x86 and I connected the ZTE modem module via usb with a Mini-PCIe WWAN to USB adapter. I installed the packages:
usb-modeswitch
kmod-mii
kmod-usb-net
kmod-usb-wdm
kmod-usb-net-qmi-wwan
uqmi
kmod-usb-net-cdc-mbim
umbim
kmod-usb-serial-option
kmod-usb-serial
kmod-usb-serial-wwan

in short, all the packages of the guide page "How to use LTE modem in QMI mode for WAN connection" but at the end

root @ OpenWrt: / # ls -l /dev/cdc-wdm0
ls: /dev/cdc-wdm0: No such file or directory

the module is recognized like this:

root @ OpenWrt: / # lsusb
Bus 002 Device 001: ID 1d6b: 0001 Linux 5.4.188 uhci_hcd UHCI Host Controller
Bus 004 Device 001: ID 1d6b: 0001 Linux 5.4.188 uhci_hcd UHCI Host Controller
Bus 001 Device 002: ID 19d2: 1485 ZTE, Incorporated ZTE Technologies MSM
Bus 001 Device 001: ID 1d6b: 0002 Linux 5.4.188 ehci_hcd EHCI Host Controller
Bus 003 Device 001: ID 1d6b: 0001 Linux 5.4.188 uhci_hcd UHCI Host Controller
Bus 005 Device 001: ID 1d6b: 0001 Linux 5.4.188 uhci_hcd UHCI Host Controller

In your opinion is it possible to make it work correctly?

all the extra spaces probably make it fail, or is it a bad C&P ?

hi

no, it's only a copy/paste error while writing the post....

So you have removed the modem from a MF286 and connected it to an x86 VM. This should work. From the page about running the whole MF286 with OpenWrt, it looks like the necessary drivers are usb-serial-option and qmi-wwan. Do those generate any log entries or errors? Do you get any /dev/ttyUSBx device?

A good test of USB modems is to plug it into a laptop or desktop running a full Linux distribution to confirm that it can connect to the Internet and see which drivers are in use.

Support for the modem was added to qmi_wwan in upstream Linux 5.17 -- I think your 5.4 is too early and you should try with snapshot or a recent, full-blown Linux-distro.

Support for the modem was only added to OpenWrt just 4 months ago in 5.10 and 5.15:

The upstream commit:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=078c6a1cbd4cd7496048786beec2e312577bebbf

1 Like

i tried a snapshot image, but I can't connect to the web interface. but snapshots have luci installed?

No, you manually have to install it afterwards.

1 Like

I tried to install LUCI offline but without success.
Following the guide I downloaded these packages and installed with opkg install:

libuci-lua_2021-10-22-f84f49f0-6_x86_64.ipk
lua5.3_5.3.5-5_x86_64.ipk
luci-base_git-22.137.71281-d6dbedd_x86_64.ipk
luci-lib-ip_git-20.250.76529-62505bd_x86_64.ipk
luci-lib-jsonc_git-22.079.54693-45f411b_x86_64.ipk
luci-lib-nixio_git-20.234.06894-c4a4e43_x86_64.ipk
luci-mod-admin-full_git-19.253.48496-3f93650_all.ipk
luci-theme-bootstrap_git-22.137.47365-c19020b_all.ipk

rpcd-mod-luci_20210614_x86_64.ipk
rpcd-mod-rad2-enc_20190109_x86_64.ipk
rpcd-mod-rrdns_20170710_x86_64.ipk
luci-app-uhttpd_git-22.029.54222-e3fbfe9_all.ipk


luci-app-firewall_git-22.089.67453-0eb3aeb_all.ipk
luci-app-opkg_git-22.043.53495-1e6f630_all.ipk
luci-proto-ipv6_git-21.148.48881-79947af_all.ipk
luci-proto-modemmanager_git-21.231.25157-5ff3ef7_all.ipk
luci-proto-ppp_git-21.158.38888-88b9d84_all.ipk

but even after rebooting I don't get anything ....

Where am I wrong?

Do you have uhttpd itself installed? Have you tried to start uhttpd, ie. /etc/init.d/uhttpd start ?

1 Like

downloaded uhttpd_2022-06-01-d59d732a-1_x86_64.ipk and installed.
reboot

I don't know how to help, I've never had any reason to look into uhttpd or its settings. Just for the sakes of trying something, here's the contents of /etc/config/uhttpd on my OpenWrt-routers, maybe it'll help:


config uhttpd 'main'
	list listen_http '0.0.0.0:80'
	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '[::]:443'
	option redirect_https '0'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option ubus_prefix '/ubus'

config cert 'defaults'
	option days '730'
	option key_type 'ec'
	option bits '2048'
	option ec_curve 'P-256'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

Try creating /etc/config/uhttpd with the above settings?

1 Like

done, same result :sob:

deep groan

Fine, what image did you use? If I built you an image to try with that included Luci and all the QMI-stuff, would that help?

1 Like

of course!
thank you very much !! :star_struck:

i would need an x86 image with lights and qmi_wwan for zte MF286D

Yes, but which image? Virtualbox? Vmware? GRUB? GRUB EFI? Something else? There are a lot of options and I can't know what you need.

1 Like

i use proxmox and for import disk you have to use
openwrt-x86-64-generic-squashfs-combined.img or openwrt-x86-64-generic-ext4-combined.img.

it's the same for me

K. It'll take a while to build.

2 Likes

I zipped up all the different images the default settings spat out, feel free to choose whichever one suits you best. The images are inside bin/targets/x86/64/ : https://www.dropbox.com/s/fb2bfcqkbvbs4fk/x86_64.zip?dl=1

1 Like