X86 for Fibre Optic connection

Hi

I am using x86 with openwrt and I am really happy with the setup. I am changing my service provider and they are giving an option to use my own modem. Can I use x86 as modem and router?

Thanks
Badri M

You don’t use modems for fiber, modems convert analouge signals to digital. Fiber has digital signals to begin with, you use a mediaconverter or a fiber module if you have a router with SFP.

There isn't the one and only fibre standard, it depends on the requirements of your ISP and its local fibre deployment. These days, in the consumer market, it's often a variant of GPON setups, where multiple households are multiplexed onto a single fibre - for these you do need a kind of (ISP blessed) modem (ONT) handling accounting, decryption and de-multiplexing.

But it depends...

Sadly ISPs generally aren't very good at documenting or communicating the details to their customers - so don't go shopping until you really know what you're going to need.

3 Likes

And even worse is that service-over-fiber most often isn’t standardized per country either so a new ISP in the future probably comes with its own new fiber.

And not even the fiber hardware is standardized as for RJ-45 in comparison. You have different connectors, different fiber materials, different polish, different wavelength etc.

If possible, just get a fiber <> ethernet media converter from them, and use your x86.

Assuming there's actually a fiber coming into your house / flat.

most of the ISP will install some sort of ONT inside your house (or outside your house) which have several ports for triple play service which is usually:

  • a rj45 for the internet connection, this is where you put your own router in.
  • a rj11 for landline, this is where you put your handset
  • a coaxial/another rj45, this is where you plug the Set top box for Cable TV access.

Below description I found it in ISP's site.

You can connect your own equipment to the Ethernet connection of the Optical Network Termination Unit (NT):

Ethernet connection with RJ-45 plug for use of UTP (twisted-pair) cables.
The NT must be connected to a 230V mains voltage, via the supplied low voltage adapter.
Note: use the NT we supply (with Ethernet connection and RJ-45 plug). The fiberglass in the FTU (where the glass is mounted) is very fragile. We therefore strongly advise against disconnecting the FTU from the NT (with Ethernet connection). There are costs associated with a repair.
With GPON, Gigabit Passive Optical Network technology, which we have been using since 2019, the NT is an indispensable part of the connection. So you cannot delete this. With the technique "Active Optical Network (AON)", the NT is a media converter, the specifications are available for this:

IEEE 802.3 100Mbit (100-Base-BX-U) or 1Gbit (1000Base-BX-10-U) (bidirectional Full duplex transmission, no auto-negotiation, no pause frames)
SFP Specs: TX 1310nm / RX 1490/1550nm
14 km range
>15 dB power budget
Class 1 laser product
Transmit power -3 ... -9 dBm
Receive power -3 ... -22 dBm
Fiber type is singlemode Fiber (9/125) with SC/PC connector (blue) or SC/APC connector (green). The connector used in the FTU may differ. Connect these via a coupling block of the correct type (color). Note: never connect different colors!

I understand now that x86 router is enough to do setup. Thanks for the clarification.

They say that they have to create VLAN for internet, IPTV and phoneline. But in my router I dont see option for VLAN. Am I missing something or not installed?

Regards
Badri M

It seems that they provide a mediaconverter or you can use your own SFP.

You can’t really see the VLAN. They need to give you the VLAN ID and then you just make the same VLAN in your switch (normally VLAN2 in OpenWRT WAN standard setup) and route it as usual.

I have a 8 port x86 router. Do I need to add a managed switch? Or I can configure VLAN in my router itself?

Thanks
Badri M

X86 hardware should have direct CPU ports, eth0 through eth7. You would connect one, for example eth0, to the ONT and attach eth0 to the wan network. If a VLAN tag is needed it would be created with the notation eth0.N (N is the VLAN number) instead of just eth0.

You can create other networks with additional VLAN tags for other services. These would probably just be dumb pass-throughs to ISP-provided phone and TV hardware. This can be done in the X86 if you have enough ports, or a managed switch.

Thanks.

I am not that good. But below is my understanding.

Port 0..7. Connect eth0 to ONT. Assign eth1 as eth0.1, eth2 as eth0.2 and eth3 as eth0.3 like that?

Here the ISP has given all the information but most of them i didnt understand.

https://www.kpn.com/service/internet/wifi-en-modems/eigen-modem-instellen-en-gebruiken.htm

Regards
Badri m

I don't speak dutch but it's enough like German or English that I think

VLAN 4 handelt het televisiesignaal af. VLAN 6 zorgt voor internettoegang en telefonie (VoIP).

This means vlan 4 is for IPTV and vlan 6 is for VOIP. They don't seem to explicitly say what internet access comes on so I'm guessing it's untagged.

This means if you plug the fiber wan to eth0 that you should make eth0 your wan, and you make eth0.4 the IPTV interface, eth0.6 the VOIP interface.

You can make TV available on say the second Ethernet port by making an interface that's a bridge between eth0.4 and eth1. Similarly you could plug a VOIP phone to eth2 and make a bridge between eth0.6 and eth2

1 Like

Hi

I tried to add a new interface to create interface like above said but I am getting Invalid UCI identifier message. How do I create vlan in an x86 router? Any help is appreciated.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb2:6000:d348::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth1 eth2 eth3 eth4 eth5'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config interface 'eth1'
        option proto 'dhcp'
        option ifname 'eth1'

config interface 'DMZ'
        option ifname 'eth1'
        option proto 'dhcp'

This is my current config.

Thanks
Badri M

I managed to configure this. Is below config is right?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb2:6000:d348::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'
        option ifname 'eth1 eth2 eth3 eth4 eth5 eth6 eth7'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config interface 'eth1'
        option proto 'dhcp'
        option ifname 'eth1'

config interface 'DMZ'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'VLAN4'
        option ifname 'eth0.6'
        option proto 'dhcp'
        option type 'bridge'
        option igmp_snooping '1'

config interface 'VLAN6'
        option proto 'dhcp'
        option ifname 'eth0.7'
        option type 'bridge'
        option igmp_snooping '1'

Thanks
badri M

A port (e.g. eth1 or eth0.4) can only be in one bridge. You can have different VLANs on the same port in different bridges.

If you're running 21.02 use the new bridge notation:

config device
    option name 'br-tv'
    option type 'bridge'
    list ports 'eth0.4'
    list ports 'eth7.4'

The above creates a bridge for VLAN 4 TV service from port 7 to the ONT plugged into port 0. Plug the TV box into port 7, it will receive TV packets tagged with VLAN 4 which is what it would expect being plugged directly to the ONT.

Hi @mk24

Thanks for the suggestion. I dont understand many things. With above given config which one I should replace? Or is it possible to correct my above config and share with me?

Thanks
Badri M

I think I should create a new topic and close this one. Thanks for everyone's help.

Thanks
Badri M

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.