X86_64 OpenWrt in virtual box


I have built my own openwrt firmware -ver 19.07 and i successfully imported the VDI under Sun virtual box. But while it boot up it says "Please press enter to activate the console". After pressing the enter it again prompt the same thing. Sone this multiple time and its same. I have included "kmod-usb-hid" also.

Can anyone please suggest!!
Thanks in advance :slight_smile:

Welcome... please provide the following info...

OS Version?
VirtualBox Version?

VBoxManage showvminfo YOURVMNAME --details

Please use the "Preformatted text </>"

Vbox Ver: 5.2.10
OS- Win10

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe showvminfo openwrt-sbox --details
Name:            openwrt-sbox
Groups:          /
Guest OS:        Linux 2.6 / 3.x / 4.x (64-bit)
UUID:            5e12b255-6c16-4ed6-bc86-ba026ea6ba09
Config file:     C:\Users\jdixit\VirtualBox VMs\openwrt-sbox\openwrt-sbox.vbox
Snapshot folder: C:\Users\jdixit\VirtualBox VMs\openwrt-sbox\Snapshots
Log folder:      C:\Users\jdixit\VirtualBox VMs\openwrt-sbox\Logs
Hardware UUID:   5e12b255-6c16-4ed6-bc86-ba026ea6ba09
Memory size:     1024MB
Page Fusion:     off
VRAM size:       16MB
CPU exec cap:    100%
HPET:            off
Chipset:         piix3
Firmware:        BIOS
Number of CPUs:  1
PAE:             off
Long Mode:       on
Triple Fault Reset: off
APIC:            on
X2APIC:          on
CPUID Portability Level: 0
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          on
Time offset:     0ms
RTC:             UTC
Hardw. virt.ext: on
Nested Paging:   on
Large Pages:     on
VT-x VPID:       on
VT-x unr. exec.: on
Paravirt. Provider: Default
Effective Paravirt. Provider: KVM
State:           running (since 2020-05-08T09:07:01.452000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: off
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0):            IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Storage Controller Name (1):            SATA
Storage Controller Type (1):            IntelAhci
Storage Controller Instance Number (1): 0
Storage Controller Max Port Count (1):  30
Storage Controller Port Count (1):      1
Storage Controller Bootable (1):        on
IDE (1, 0): Empty
SATA (0, 0): C:\Users\jdixit\Desktop\openwrt-x86-64-combined_keyboard-ext4.vdi (UUID: 4c6e27a7-7549-46f7-ab08-3b3651e16a50)
NIC 1:           MAC: 080027E5D832, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 1 Rule(0):   name = Rule 1, protocol = tcp, host ip =, host port = 2022, guest ip =, guest port = 80
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Pointing Device: USB Tablet
Keyboard Device: PS/2 Keyboard
UART 1:          disabled
UART 2:          disabled
UART 3:          disabled
UART 4:          disabled
LPT 1:           disabled
LPT 2:           disabled
Audio:           enabled (Driver: DSOUND, Controller: AC97, Codec: AD1980)
Audio playback:  disabled
Audio capture: enabled
Clipboard Mode:  disabled
Drag and drop Mode: disabled
Session name:    GUI/Qt
Video mode:      720x400x0 at 0,0 enabled
VRDE:            disabled
USB:             enabled
EHCI:            enabled
XHCI:            disabled

USB Device Filters:


Available remote USB devices:


Currently Attached USB Devices:


Bandwidth groups:  <none>

Shared folders:  <none>

VRDE Connection:    not active
Clients so far:     0

Capturing:          not active
Capture audio:      not active
Capture screens:    0
Capture file:       C:\Users\jdixit\VirtualBox VMs\openwrt-sbox\openwrt-sbox.webm
Capture dimensions: 1024x768
Capture rate:       512 kbps
Capture FPS:        25
Capture options:    ac_enabled=false


Configured memory balloon size:      0 MB
OS type:                             Linux26_64
Additions run level:                 0

Guest Facilities:

No active facilities.

C:\Program Files\Oracle\VirtualBox>
1 Like

These are the defaults I have for these;

Guest OS:                    Linux 2.6 / 3.x / 4.x (32-bit)
Pointing Device:             PS/2 Mouse
Keyboard Device:             PS/2 Keyboard
UART 1:                      I/O base: 0x03f8, IRQ: 4, disconnected, 16550A
PAE:                         enabled
X2APIC:                      disabled

I'd probably recommend;
+toggling the mouse off etc.
+trying the 32bit profile
+trying VirtualBox 6 ( if it's not a pain... if you have many other critical VM's maybe try on a different machine)

Well, thanks a lot for reverting so quick on the matter!!
But i have another openwrt (openmptcpruter) runing in my virtual box. this is prebuilt VM that i got from the website and it worked. but the one that i compiled is giving the issue.
Its taking the input from my keyboard but pressing enter is throwing me again on same text - "please press enter......."

I see... so it's custom compiled... did/can you try just a vanilla image?

Sorry, But i did not get your point - vanilla image?

The officially built software. Not one that you modified.

guide (windows might be different a bit... sorry I don't use if often )

gzip -d openwrt-*x86-64-combined*.img.gz
VBoxManage convertfromraw --format VDI openwrt-*x86-64-combined*.img openwrt.vdi

Well. i took the latest source from git and added some packages of routing and jamvm, nothing more.
i ll try the one you are suggesting right away.

1 Like

Yes that worked!! the Vanilla image worked.
What is then wrong with the custom one. :frowning_face:

1 Like

winner! :sneezing_face:

i've never used this... but it does appear to be old / unsupported...? either way... just begin building again... and add your stuff one by one :robot:... that way you'll be able to work out which one is causing the problem...

one good thing about VM's... super fast building / testing...

Hmmm!!! Ok
can i have the config of this vanilla image and compare with mine if there is something like root fs size/block or console setting if need to be done during compilation.

Thanks you for your help!!