X5000R wireless 5GHz issue

Here

 -----------------------------------------------------
 OpenWrt 21.02.2, r16495-bf0c965af0
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option cell_density '0'
        option htmode 'HE20'


config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 
        option ssid 'OpenWrtX5000R_2.4GHz'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'


config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtX5000R_5GHz'
        option encryption 'psk2'
        option key 

No Country Code showing for either 2.4 GHz, or 5 GHz.

This should go in each config wifi-device section -

option country 'US' (using my country code here)

Add the option, commit it, and re-post your WiFi configs again.

1 Like

I am outside at the moment.

I will try it again when I get home.

Yes, correct I did insert the setting at config wifi-device section,
and I keyed in my own country code. Not 'US'

The result is Device is not active, as I mentioned earlier.

Wouldn't it make a difference, if I key 'US' for the country that I pretend to be coming from?
Well, I will not be compliant with the regulatory domain :thinking:

You need to use your own country code.

For some reason, your changes are not showing up in the wireless config file.

Instead of using UCI from the SSH command line, I would suggest downloading the nano text editor package.

opkg update
opkg install nano

Note: If you're a Windows user, WinSCP is an excellent tool...

Backup your configs first.

Then, just edit the config file, make your changes, and save it.

No need to do a uci commit when using a text editor.

Finally, you need to restart wireless...which is the step I think your missing

Run wifi up to bring up all wireless radios.

2 Likes

I backed up the tar.gz file, and unziped it to modify the etc/config/wireless file.
I add the ``option country 'US'` just for the sake of testing only.
Later I will change to my own country code.

Save the wireless file, after editing using notepad++.
Created the tar file with 7-zip and then compressed again in gz format

Uploaded the modified gz file using Restore
Once was restorsed, the router will automatically rebooted itself

Once the router rebooted, I restarted the interfaces.
I ssh into the router, and do a: cat /etc/config/wireless
The result was the same, the line that I keyed in option country 'US'
in the config wifi-device section, it did not stick.
What I typed was simply not showing up.

The edit with Notepad++ could be exaclty what needs to be avoided.

So make sure your editing correctly by clicking 'Unix'

1 Like

^this.

You avoid the unix/windows translations issue. unix uses LineFeed only for new lines. Windows uses Carridge Return/Line Feed for new line. that WILL make unix barf.

WinSCP gives you dual explorer type windows and you can copy/paste into the internal editor and it will save it to your router with the correct unicode.

1 Like

Before I went into this path.........

I did tried another path, that is install nano in my router
SSh into my router and open up the wireless text file:
nano etc/config/wireless

Open the file with nano, and add the line:
option country 'US' into config wifi-device section for both Radio0 and Radio1.
I saved the file, exit then I do:

uci commit wireless
reboot

The router rebooted, I SSH again and did a: cat /etc/config/wireless
But in the end, the result is the same, I cannot get
option country 'US' to stick. This line is completely disappeared.

So shoud I try WinSCP?

As mentioned above, when you use a text editor, you don't need to run uci commit.

Also mentioned above, run wifi up after editing and saving the config file...a reboot is not needed.

And finally (you guessed it...mentioned above), you need to use your own country code.

Give it a try...I use it almost exclusively.

It's also has a editor (will default to Notepad, or whatever your default text editor is), so the same principles apply for editing in WinSCP as in nano. (make the change, save it, no uci commit, run wifi up, use your own country code).

Ok now the line: option country 'XX' (example only XX is not a real country code) is sticking

But...........I have some problems:

  1. In Luci, Network, Wireless, click on edit, go to Advanced Setting tab, Country = BLANK/Empty

  2. 2.4Ghz radio is completely down, and it is not active, no matter how times I restart. 5GHz radio is working.

  3. RPCerror message in red appeared. Once you press the dismiss button, the Luci web page will
    not load at all. Only can see the spinning wheel, with the message: loading view....I rebooted
    the router, and now wireless GUI is missing, so now to fix this problem?

I ssh into router, and type the command: nano etc/config/wireless,
nano cannot find the wireless file.

I went ahead and grabbed the sysupgrade firmware and reinstalled OpenWRT again.
Only then, I am back in business.

I think is best to leave out the option country 'XX', so that it will run more stably.


I ran the steps I posted for 2 or 3 Country Codes, and it worked every time.

I think I would do a reset, and re-configure from scratch.

Hi, would you mind telling me which router you are testing? X5000R?

The principles for editing config files in OpenWrt work the same.

It's not device dependent.

If you're having this much difficulty with manual configuration, try rolling back to 21.02.1 or 21.02.0, and see if LuCI configuration works.

I would still re-configure from scratch with 21.02.1 or 21.02.0.

If you want to try the snapshot -

https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-totolink_x5000r-squashfs-sysupgrade.bin

Note that it does not include LuCI, so you will have to install it.

opkg update

opkg install luci

Good luck.

Thank you for your patience & guidance. :+1: :grinning:

I manage to get it working now.

When I encountered the Luci was crashing, I would just do *perform reset* as shown in your previous post.

I edited using Nano on the /etc/config/wireless text file on the 5GHz and added:
option country 'XX" XX- my country code.
save the file
run the command wifi down and then wifi up
everything is working fine.

As long as I don't touch the 5GHz radio interface setting, and press Save & Apply button,
I won't crash Luci wireless interface.

I have no idea of rolling back to the previous release. Like: 21.02.1 or 21.02.0

This link above that you have shared, which release it this?

Thank again for your help. :clap: :slightly_smiling_face:

Ok never mind, I think I found** 21.02.1** release:

I can just install it on top of the existing firmware, right?

Attention to all X5000R owners out there,

I know for the time being the workaround solution is to add wireless settings
/etc/config/wireless, in order to use the 5GHz radio

But I have searched on Github, some users have a permanent solution which
can render LUCI GUI to work in perfect harmony with 5GHz radio by following
the solutions below.

Please spare a minute or 2, and share which solutions work 100%.

So far, I have found some users on Github who have replied with their solutions.
In total 2 of them, see below:

  1. Changing wireless settings breaks wireless [X5000R] #5468
    https://github.com/openwrt/luci/issues/5468
    Solution:

had the same issue with latest stable 21.02.2 - add this channel option:option channel 'auto' fixed it

  1. [Totolink X5000R] no wireless channel selection in 5GHz AX mode #9379
    https://github.com/openwrt/openwrt/issues/9379
    Solution:

I doubt if OpenWrt 21.02 has proper 11ax support. I remember 11ax support wasn't done when 21.02 branched off. I'm using this router with the master snapshot image and wireless channel shows up properly in LuCI.

:point_up::point_up::point_up:
This user said, just use the master snapshot image to solve the problem.
Where to get the master image?

Here? https://downloads.openwrt.org/releases/21.02.2/targets/ramips/mt7621/openwrt-21.02.2-ramips-mt7621-totolink_x5000r-squashfs-sysupgrade.bin

Or

Here? https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-totolink_x5000r-squashfs-sysupgrade.bin

What is the difference between the 2 links? The last link does not state: 21.02.2

Most appreciated. :slightly_smiling_face:

Thank you.

Link #1 = stable release 21.02.2
Link #2 = snapshot of master branch (=the development branch)

Suggested reading:

https://openwrt.org/faq/difference_between_a_release_and_a_trunk_build
https://openwrt.org/releases/snapshot
https://openwrt.org/about/history#branch_logic

Thanks for the links.

I just noticed the OpenWrt team has released 21.02.03

On what basis, in the tree, is considered a branch. I saw the picture with Fix, A, B, C, but don't understand what it really means.

I installed v21.03.0-rc6 today and it is fixed out of the box

itworks

5GHZ still broken in the 22.03.3 release version

When I enable the 5Ghz WiFi in LuCi it always states that the device is not active with the wireless not associated

https://i.imgur.com/YyJVgXO.png

Seems to be fixed by this snapshot (r22036-1a1455ccb0c)

https://i.imgur.com/2ROUujw.png

You can also see that the name is fixed with the capabilities separated with a /

Think this might have something to do with the changes made to package/kernel/mt76/Makefile or to target/linux/ramips/dts/mt7621_totolink_x5000r.dts files, but idk.

Checkout this post if you are on the snapshot.

diff is REALY big! Links might be broken