WS-AP3825i 5GHz Throughput Limitation on OpenWrt 23.05.3

Hi everyone,

I am using OpenWrt firmware version 23.05.3 r23809-234f1a2efa / LuCI openwrt-23.05 branch git-24.073.29889-cd7e519 on an Extreme Networks WS-AP3825i access point. On the 5GHz band using AC mode, I am only achieving a throughput of about 460Mbps. From my understanding, this access point should theoretically support speeds up to 1300Mbps.

I have already tried the following:

  • Ensuring the latest firmware and LuCI versions are installed.
  • Tested with ath10k-firmware-qca988x and kmod-ath10k and (the "-ct" maxes out at about 450Mbps).
  • Setting the channel width to 80MHz.
  • Verifying that my client devices support 802.11ac and are capable of higher speeds.
  • Checking for interference and ensuring optimal placement of the access point.

Despite these measures, the throughput remains capped at about 460Mbps. Has anyone else experienced similar issues with the WS-AP3825i on OpenWrt? If so, were you able to resolve it and achieve higher speeds? Any insights or suggestions would be greatly appreciated.

Thank you!

You must test forwarding, not against router soc. And have 3x3 client to reach speed.
450 and 460 fit un up to 1300

Thank you for your quick response.

I have tested the network throughput by measuring the forwarding performance rather than against the router SoC.

My current client device is an iPhone 15 Pro, which supports 2x2 MIMO with a theoretical data rate of 1200 Mbps on the 5 GHz band. Despite this, the observed throughput is around 460 Mbps. I understand that using a 3x3 MIMO client could potentially offer higher speeds, but I'm currently limited to a 2x2 MIMO client for my tests.

If there are any additional configurations or optimizations that I might have missed, or any suggestions for further tests, I would greatly appreciate your input.

Thank you!

Theoretical rate 866Mbps in 5GHz band ac 80MHz 2x2, more like 800Mbps if the surroundings are really clean.
Enable firewall offload.Probably with mods described here: Massive PPPoE performance drop in 23.x with Archer C7 v2 - #5 by brada4 (mods apply equally to snapshots and 23..3)

Thank you again for the instructions

Firewall offloading is set:
firewall.@defaults[0].flow_offloading='1' firewall.@defaults[0].flow_offloading_hw='1'

And the mods described here: applied.

I corrected MSS in /etc/nftables.d/mssfix.nft and applied the patched fw4.uc to /usr/share/ucode/fw4.uc, followed by firewall check & restart.

However I have absolutely no improvement in throughput speed.

Did I miss something?

Set that to zero. As you see my intent was to operate ARP, shich absolutely does not go with hardware offload.

Ok, thank you.

Now I have:


Followed by a reboot.

But unfortunately still no improvement in throughput speed.

Check nft list ruleset | head -20
It should list br-lan, wan and pppoe-wan (maybe you need to delete hw_offload from /etc/config/firewall, im not an expert on ucode fw library)

When I run nft list ruleset | head -20, I get nothing.

As I understand I have no rules defined. Please note I'm running dumb AP.

Edit: My bad. Read the above post to quickly.

There is a bridger package to mangle bridge interfaces so that they can use offloads. No idea how it works/configures.
You had to mention uncommon setup, as offload only works for NAT

ethernet switch does not use CPU at all. There is one gigabit port in that switch connecting via CPU to radio.
Ethernet connection is gigabit up gigabit down, not 866 with collisions.

Thank you and my apologies for not mentioning Dumb AP.

I don't know if this is correct but I installed and configured the bridger package and set enabled option enable_offload '1'.

Unfortunately I still have no improvement in throughput speed.

If anyone is using Extreme Networks WS-AP3825i access points as Dump AP and is getting throughput speeds over 800Mbps on 5 Ghz band using AC I'd really love your insights and suggestions.

If you could bridge eth0.2 and eth0.3 and check unaccelerated throughput via CPU?