Wrt54gl archeology

Hi! I've found an old Linksys Wrt54gl Router (hardware version 1.1) in a drawer. Before throwing it to trash I've decided to dust it off and try to do something useful using it. I have many APs for testing purposes but none of them is capable of act as a enterprise wifi network. I can do that using a Raspberry pi, but it could be awesome to achieve it using this old router if possible. If finally I get it, that could save me some time each time I need to test something on an Enterprise network environment.

Goal: to create a wifi network acting as enterprise network using freeradius.

Difficulties: very few space on the device, is pretty old. It seems to install freeradius2 package and all its dependencies is not easy.

What I've tried so far:

-1st fail: Using the latest available openwrt firmware for this old router (backfire 10.03.1) from this link: https://archive.openwrt.org/backfire/10.03.1/brcm-2.4/openwrt-wrt54g-squashfs.bin I tried to uninstall some packages using opkg but no matters what I uninstall... it seems that freeradius2, libopenssl, wpad (instead of wpad-mini) and some more are impossible to install. I always "break" the router uninstalling something essential and it breaks... otherwise is impossible to install all I need. So fail this way...

-2nd fail: I've decided to create a custom firmware version using imagebuilder following this guide: https://openwrt.org/docs/guide-user/additional-software/imagebuilder?do=profile . Downloaded the imagebuilder (https://archive.openwrt.org/backfire/10.03.1/brcm-2.4/OpenWrt-ImageBuilder-brcm-2.4-for-Linux-i686.tar.bz2) and started to play.

The first problem I found was that on modern Linux, the image builder is not working. No problem, I downloaded an ancient Ubuntu iso and created a virtual machine for that. Now I can use it and compile my custom stuff. Great! we are on the road... I started to "play" creating different adding and removing packages. I've read that the created bin file must have a size lower than 3866624 bytes and mine has 3153920 so we are good! but when I try to flash the image through the GUI, it shows an error saying "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform".

Not sure what can be happening. I'm pretty sure that I've downloaded the right stuff for the right version for the right model... I'll paste my build command, maybe it could be useful to know what is happening. In this way you'll see the packages I'm trying to use:

make image PROFILE=brcm-2.4 PACKAGES="luci luci-app-firewall luci-i18n-english luci-lib-core luci-lib-ipkg luci-lib-lmo luci-lib-nixio luci-lib-sys luci-lib-web luci-mod-admin-core luci-mod-admin-full luci-proto-core luci-proto-ppp luci-sgi-cgi luci-theme-base luci-theme-openwrt uhttpd base-files dropbear openssh-sftp-server busybox dnsmasq iptables wpad ip -ppp-mod-pppoe -ppp -kmod-pppoe -kmod-ppp kernel kmod-crypto-aes kmod-switch wireless-tools libiwinfo nvram opkg libltdl libopenssl freeradius2 freeradius2-mod-eap freeradius2-mod-chap freeradius2-mod-eap-gtc freeradius2-mod-eap-peap freeradius2-mod-eap-tls freeradius2-mod-eap-ttls freeradius2-mod-pap freeradius2-mod-mschap freeradius2-mod-eap-mschapv2 freeradius2-mod-eap-md5 freeradius2-mod-exec freeradius2-mod-files freeradius2-mod-radutmp"

As you can see on this command, the profile selected is the right one (brcm-2.4) and the compliation finish ok without errors. The resulting bin file I'm using is called "openwrt-wrt54g-squashfs.bin". It is called in the same way as the file I can download and flash flawlessly from the link I pasted before on this post.

Maybe am I missing some essential package? Any help? Thanks! :slight_smile:

You're missing that this device only has 16 MB RAM (before even talking about the 4 MB flash), which was extremely little 15 years ago and totally insufficient a decade ago.

If you want to experiment, 5-10 EUR get you a long way on the used market, for a device with >= 8/64 (and with a little patience, you'll find even much better things than that) that can easily run modern OpenWrt and isn't a walking fleabag of security issues. The WRT54GL however deserves to rest in pieces.

1 Like

I was afraid that someone would say that. I know is very very old. If finally is not possible to get what I want is ok. I'm doing this just to learn and for fun. I hope to somebody to give some nudge or recommendation about the process. Maybe I'm doing something wrong. Not sure because is the first time I do something like this. I'm referring to compile a custom Openwrt image. If you are familiarized with the process and everything sounds good for you regarding the process, then I'm in trouble :cry:

Anyway... Did you say that there are other old models (not as old as this ancient one) which are able to do what I want... and maybe supporting WPA3? WPA3 is another feature I'd like to test but the latest firmware for the WRT54gl is not capable of it.

A recommendation for a cheap and old router capable of WPA3 and freeradius stuff with some Openwrt image? thank you!

The BT Home Hub 5 Type A is one of these devices, it doesn't break speed records (although it runs circles around any wrt54, 2*500 MHz vs 200 MHz), but has good WLAN (WPA3 supported) and decent amounts of flash/ RAM (128/128); it regularly sells for 8-9 GBP used (plus shipping from the UK), just to name one example.

@oscarakaelvis, welcome to the community!

You can't uninstall files in the built firmware, they take more space having a "delete mark" on them.

Use current snapshot (remember, no web GUI - you won't be able to use it anyways).

(I'll note that you won't enjoy use of the device like a newer one, though.)

Thanks for the comments. Probably I'll buy one of that routers that @slh is saying.