I'm trying to make a dumb wired ap from wrt32x
Connection looks simple:
modem lan port --> router lan port
But router can't connect to the internet.
I did dumb ap hunded times... for archer c7, it was just enough to make eth0 and eth1 as tagged, and it worked perfectly. But now I've been wracking my brain to try different options and solutions... Unsuccessfully.
I'm requesting your help, please help me make it work.
my working /etc/config/network on archer c7:
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option gateway '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '192.168.1.1'
option ipaddr '192.168.1.3'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 1 2 3 4 5 6t'
This config for wrt32x that doesn't work:
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.2'
option device 'br-lan.1'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'eth0:t'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
AFAIK, the wan port will not be eth0 in DSA. It will likely be "wan" (without the quotes). Try replacing eth0 in both locations with wan and see if that fixes the issue.
You don't need a bridge-vlan if all the ports are going to be untagged. From a default configuration, just move the "wan" port out of the wan network (which can be deleted entirely on a dumb AP) and into the existing br-lan.
But the main problem is you don't have a gateway or DNS set in lan.
You both wrote about wan port, and I don't understand why. I wrote that I use lan port.
I put eth0 because I thought that it requires bridging via some virtual interfaces?!
But thank you a lot for a solution!
It was simple missing gateway and dns server.
Putting those vlan can be simply disabled and br-lan.1 deleted. Also deleting eth0 and wan from br-lan bridge will not make a difference.
If put minimalistically working config will look like:
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.2'
option gateway '192.168.1.1'
list dns '192.168.1.1'
option device 'br-lan'
This is an optional step, but moving the now-unused wan port into br-lan will make it usable to connect a LAN device to it the same as the other lan ports. It will be hardware switched to the upstream LAN.
For a minimal dumb AP you don't have to do anything with the switch or Ethernet ports at all, since at least one of them will already be in the lan network. The dumb AP instructions should be clearer on that point.
For some reason it was required to make eth0 & eth1 when I was making dumb ap from archer c7...
As topic was solved can I ask another question?
I have a vdsl modem also running on openwrt, which is doing more functions than dumb aps as having dhcp server, firewall, time server and etc.
As I have a more powerful router wrt32x would it make more sense to make a modem "dumb" and router "smart"?
Can it be more beneficial then it is now?
Many consumer all-in-one wireless router devices include a 5-port hardware switch, and it is specifically this type of device that I will be addressing for the following statements:
From a default installation of OpenWrt, 4-ports are generally assigned to LAN and 1 is assigned to WAN.
After following the Dumb AP guide, the upstream network can be connected to one of the LAN ports and the device will operate as a 4-port switch + AP.
If it is desired to include the WAN port (as physically labeled on the hardware case) included in the dumb AP configuration, a simple tweak is needed:
on swconfig devices, usually the WAN port must be changed from 'untagged' to 'off' on its current VLAN (often VLAN 2) and set to 'untagged' on the same network as the rest of the LAN (often VLAN 1).
In the case of DSA, the port is addressed by name (i.e. "wan"). The older swconfig notion of eth0, eth1, is abstracted and no longer appropriate in DSA based devices. Therefore, if you attempt to use eth0, eth1, it will not have the desired effect. Instead, address the ports by name ("lan1"... "lan4", "wan").