WRT3200ACM Switch option missing within Luci in OpenWrt 21.02.0-rc1

The other day I updated OpenWRT on my LinkSys WRT3200ACM from version 19.07.7 to 21.01.1-RC1 - (I know its a release canidate and there might be issue).

But prior hand i was using OpenWRT as a router - upon/after updating the system i configured the WRT3200ACM as just a dumb access point( via OpenWRT Wiki guide) - connecting to a new Pfsense system handling everything now.

When looking into Vlan setups with Pfsense- i went to the OpenWRT Luci gui and noticed the switch option is no longer present.

Did the new firmware remove this option from Luci - Since it now uses Dsa verse swconfig?

Or does turning it into a dumb access point do this? If this is the case - is there any option/ability to restore switch option within a dumb access point configuration via a package etc.. If not no biggie - I'm more curios. As i wanted to setup Vlans from Pfsense to my Netgear GS724T switch and another to the WRT3200ACM switch ports.

Don't believe this has found its way into the 21.x stable.

wasn‘t the VLAN config „switch“ menu permanently removed and VLAN is now on a sub tab in „interfaces“?

Sadly, I see no option for it under interfaces.

Yeah that might be - I had seen the link you provided previously which listed mvebu. Which is what the Linksys Wrt3200acm shows under for target and then sub-target of cortexa9.

The gitlog indicates as not pushed to 21.x, not sure what the game plan is, iirc there might have been some banter on the ML.

LINKSYS EA7500V2 has the same problem.

Yes.

The absence of DSA switch support in LuCI is mentioned in the release notes of the RC ....

Known issues

  • DSA support is new and might not be complete or fully working
  • The LuCI web interface has no support for DSA yet

I think that the plan is to backport the LuCI part from master to 21.02 before the final release (or rc2), but so far it has not been done.

2 Likes

Understood - is there a guide on how to do it via an alternative method for now? Such as via editing the network file in nano editor?

Thank you

vi is the current way, syntax, example

1 Like

Apologies for being slow to respond, but the linked example in the prior post has "broken" since then: under certain VLAN setup use cases (2 of my 6 routers fall in this category, and based on recent commits I believe I have this working now).

The problem I was seeing is that the router would route local packets between ports on the VLAN but at the network level the switch would drop packets -- VERY annoying to troubleshoot. In any case, here is my updated syntax and it is working as of the latest TRUNK netifd commits (3 days ago: netifd update) I am using routed networks and VLANs on all routers, I'm haven't been able to isolate the condition that creates this problem. In any case...

Here is the updated (working on trunk as of today) syntax for the /etc/config/network setup referenced in the prior post.

config device
    option type 'bridge'
    option name 'switch0'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'
    list ports 'lan4'
    list ports 'wan'

config bridge-vlan
    option device 'switch0'
    option vlan '1'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'

config bridge-vlan
    option device 'switch0'
    option vlan '2'
    list ports 'lan4'

config bridge-vlan
    option device 'switch0'
    option vlan '3'
    list ports 'wan'

config interface 'lan'
    option ifname 'switch0.1'
    option proto 'static'
    option ipaddr '10.10.1.1'
    option netmask '255.255.255.0'

config interface 'guest'
    option ifname 'switch0.2'
    option proto 'dhcp'

config interface 'iot'
    option ifname 'switch0.3'
    option proto 'static'
    option ipaddr '10.10.3.1'
    option netmask '255.255.255.0'

Changes:

  • ALL switch ports listed (new syntax) in switch device
  • switch ports changed to new list syntax in bridge-vlan sections
  • "bridge" removed from config interface section

It's possible the original syntax would work if it was modified to include all ports in the switch device section alone, but that and the removal of "bridge" from the interface section are really the only functional changes.

Link for reference on new syntax: new syntax

I need to put this in /etc/config/network for my router to work with my ISP, but it doesn't work in 21.02.0.

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option ports '4t 6'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1'

Anyone have any ideas how to write this in the new syntax?
Thanks!

1 Like

hi, did you solve?