[WRT3200ACM] Some IoT devices can't connect to WiFi APs provided by the router

I'm currently having issues with this router's Wireless on OpenWrt, that some IoT devices would not connect properly. Not sure what is required for OpenWrt to allow these devices to connect properly, or that the router itself (WRT3200ACM) is having issues with Wireless in overall (due to mwlwifi and such).

These devices in question use a smartphone app to connect. With the phone already connected to a 2.4GHz network (5GHz is currently no-go for them), you provide the Wi-Fi credentials and it'll be broadcast to such devices that are waiting to connect, and then the device will connect to that network.

However, with the APs provided by WRT3200ACM (on OpenWrt), for some reasons those devices would refuse to connect. Neither the guest AP nor the main AP worked. In the Wireless stations list, the device would show up with its correct MAC address, but no IP addresses were assigned and it showed a very slow transmit rate (1.0Mb/s). A few minutes later the device would disappear, and in the system logs, it appeared that the device was indeed authenticated, but the device (station) disconnected itself without explaining why so I can't be sure whether the device is not connecting properly, or the router is rejecting.

At one time I thought I might have gotten a bad device, but using a basic Wi-Fi hotspot I created on a computer (connected to the router via wired connection) with NetworkManager from Linux, the device connected to it without much hassle, so the problem is very likely related to the router's wireless configuration. Not all IoT devices exhibited the issue... some were able to connect to the router just fine, even on the guest AP.

I'm wondering about what might be causing the IoT devices to not connect to the router's AP. I'm having questions regarding some security-related features on my router (WRT3200ACM). However, at present, disabling these security measures did not fix the issue with some IoT devices not connecting so there might be something else that's causing the problem.

  1. I worry that "Isolate Clients" might interfere with this configuration flow. Does this feature work as intended on this router? If this indeed interferes, I would turn this off when I need to configure/pair a device, but most of the time I'd want to keep this enabled if I'm not interacting with it to keep things safe.
  2. For security concerns I'm using a Guest Wi-Fi for external devices (and switch my device to the guest network when I need to interact). Would there be any additional configuration required for such devices if they would not connect? (As said, some devices do not need any configuration to properly connect to a guest AP)
  3. Would KRACK countermeasures affect the connectivity of certain IoT devices? Given this was said to be a major security flaw I'd want to keep this enabled, and that my current smartphones and laptops are already running systems with this patched and are working without issues.

mwlwifi is known to have interoperability issues with esp8266 since day 1, chances for this to get fixed are effectively zero - Marvell didn't care during their tenure, NXP's only action was EOL'ing the 802.11ac chipsets.

In this situation the third radio (sdio/ mwifiex) might actually be more cooperative, but this easily introduces regdom issues and this radio was more meant to be used on the 5 GHz (for passive continuous DFS scans, although Linksys never actually deployed this feature) and doesn't really come with proper antennas either.


Not sure if the IoT devices are using such chips for Wireless communications... I currently don't have any IoT device that would connect to a 5GHz network, only 2.4GHz (so the third, mwifiex-powered radio may not be as helpful).

After all, 5GHz signals are very bad at passing through walls even with this router (maybe that's the nature of signals of such frequency), making the use of such signals in home IoT appliances (that needs to cover many rooms) a bad idea unless expanded through repeaters.

Currently I can only get full 5GHz signal inside my room, and have to use the 2.4GHz signal when I leave the room as the signal outside my room is very weak.

Third radio can operate on either the 2.4GHz or the 5GHz band. Disabling WWM fixes the issue, but it also reduces speeds drastically. Disabling LDPC seems to fix the issue for some.

Okay... so this is indeed a known interoperability issue with mwlwifi and some IoT wireless chips. I've read through the issue you've referred to, and the situation I had with my device was similar.

I don't know if the devices I'm having the issue with are using ESP chips, but I'll keep this in mind when adding more IoT devices in the future to avoid running into more trouble.

It's indeed possible to configure the 3rd radio to operate at 2.4GHz. Will try this if I have time. However, I'm a bit cautious as Wireless configurations are rather unstable on OpenWrt master that it often broke for unknown reasons when I change settings, and it often takes several changes back and forth, and several reboots, to get it working.

How's the signal quality and stability of the 3rd radio on OpenWrt? A long time ago I remembered seeing the 3rd radio randomly dying on me (suddenly disappared), not sure how the situation it is now. If using the 3rd radio for such devices on 2.4GHz, do I need to disable LDPC (or WMM altogether)?

Anyway, the device is currently operational using the hotspot I set up (using an Intel AX200 adapter) on a PC which I use to run some automated jobs, that I usually keep it on most of the time.

May IoT devices use ESP-8266 chips, it's quite probable that your too.

The WRT3200ACM has it's quirks, but otherwise it has been rock-solid for me.

The third radio has a little antenna, and the coverage / bandwith is not great, but it's OK for low-demand devices like IoT. This one is not affected by the issue, so you do not need to fiddle with WMM / LDPC.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.