WRT3200ACM master and client on one radio

Hey There

Im looking for an answer to one simple question.
Is the same radio can be used paralleli as a client (sta) and master (ap) on the WRT3200ACM?
I searched for it everywhere, but there is no straight answer for that...

So please WRT3200ACM owners, HELP!

Yes it can.

Okay, that's something. How?

I would like to use as a travel router with travelmate.
But if i set up the client connection it disables the master, and if i set up the master it disables the client. (Its doing it without travelmate as well)

I read lot of wiseness how should be done
1, Client and master should be on the same channel... not working.

2, Client and master should have the same SSID... which is not make too much sense because i want to use a client connection as a wifi wan, so somehow i have to identify what is my wifi and whats belongs to the hotel... but it doesn't really matter, because this hint is also not working.
3, It should be started in a specific order. I tried it back and forth the client master start, but not working.
4, You should stand on your right leg, under a ladder and enable the master with a left hand click in LuCI... surprisingly not working either.

I asked a friend to try it on his router, but its also not works for him... so it cant be a hardware problem.

So what is the trick?

Why don’t you post the wireless config you’ve tried before and see if someone can assist you. In these situations my first guess is “auto” channel and then DFS.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Well, okay. At least its not gonna hurt :slightly_smiling_face:

network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipv6 '0'
        option delegate '0'
        list dns '8.8.8.8'

config device
        option name 'wan'
        option macaddr '00:00:00:00:00:00'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option dns_metric '20'
        option metric '20'
        option ipv6 '0'

config interface 'trm_wwan'
        option proto 'dhcp'
        option metric '10'
        option dns_metric '10'

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'
        option channel '100'
        option txpower '23'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option band '2g'
        option country 'US'
        option cell_density '0'
        option htmode 'HT40'
        option channel '8'
        option txpower '30'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option band '5g'
        option htmode 'VHT80'
        option channel '153'
        option cell_density '0'
        option txpower '30'

config wifi-iface 'trm_uplink1'
        option device 'radio0'
        option mode 'sta'
        option network 'trm_wwan'
        option ssid 'HotelWIFI'
        option encryption 'psk2+ccmp'
        option key 'password'
        option disabled '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'LocalWIFI'
        option encryption 'psk2'
        option key 'password'

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        list rebind_domain '192.168.2.1:5123'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        list ra_flags 'none'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'trm_wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

I open minded for any thoughts... which could made impact on the wifi connections :smile:

Disable radio 2 for your own sanity.
You have radio 0 set to channel 100, which is DFS.

This is almost certainly causing your issue.
If you control the upstream AP, move it to a non-DFS channel and you’ll be off and racing. These devices are notoriously picky about DFS.

Your radio must do a DFS scan for a period (usually 60 seconds) and won’t come up until this is over. If it finds something it doesn’t like, it may never come up, or attempt to change channel.
Both of those will result in your STA being down (because it’s now on the wrong channel) and your AP will never come up because your STA is down.

In a hotel wifi scenario, travel mate is the best way of running everything, but you may end up needing to accept that you need to just connect on 5GHz and rebroadcast on 2.4GHz.

Ahhh, i see.

So the the ultimate answer for the ultimate question
"WRT3200ACM master and client on one radio?"

At radio1 (2,4GHz): yes, if the client and the master on the same channel.

At radio0 (5GHz): theoretically yes, if the client and the master on the same channel and the uplink not using DFS channel. Which not gonna happen too often these days, because DFS is a very common thing, especially crowded places like hotels.

Thank you very much lantis1008, you saved me from a mental breakdown :grinning: :grinning: :grinning:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.