WRT3200ACM and 21.02.0 wireless config problem

Hello to Everyone:
I am a new user of Openwrt with a config problem that I am hoping someone can solve for me.

I am using a Linksys WRT3200ACM and was running 19.07.8 problem free with an added wireless interface on the 2.4 radio. I configured this added interface with WMM mode disabled so that some older IOT's would be compatible and it has worked great just by setting it up thru the wireless overview GUI.


I have now installed 21.02.0 which uses the newer DSA Switch Architecture.
Having a problem setting up an additional wireless interface using the same process as I did in 19.07.8.
Using the Wireless Overview GUI, I created the new additional interface IOT24 on the 2.4 radio. Everything seemed OK during configuration and I kept encryption thru WPA2.

If I enable ONLY one of the two 2.4 interfaces the selected one will come online and function properly.


However, If I try to enable both interfaces together they will both report back as "Wireless is not associated" and any resetting or rebooting has no effect on clearing it up.

With the DSA Switch Architecture do I need to install an additional package to be able to do this?
Is this a VLAN config error?

I'm experienced in accessing and moving around in the configuration files via WinSCP but have no idea if the config files need to be manually edited.

Any guidance will be greatly appreciated.
Thanks in advance.

someone else had the almost same question a day ago and got a working fix. Mayybe check, if yours has the same cause: WRT3200ACM + 21.02.0-rc4: multiple Wifis on a single radio?

1 Like

Thank you for the reply! I checked out that scenario from that posting link and tried the line delete. OMG I think it's working! I need to do some more testing but all looks good right now.
I'll post my wireless config
Thank you for sharing your observation.
Be safe.

BEFORE:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '1'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr '30:23:03:db:5c:22'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option ssid 'OpenWrt'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'
	option channel 'auto'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr '30:23:03:db:5c:21'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option ssid 'U25124X'
	option disabled '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '34'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xxxxxxxx'
	option network 'lan'
	option ssid 'IoT24X'
	option disabled '1'

AFTER:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '1'
	option country 'US'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option ssid 'OpenWrt'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'US'
	option cell_density '0'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'XXXXXXXX'
	option ssid 'U25124X'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '34'
	option hwmode '11a'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xxxxxxxx'
	option network 'lan'
	option ssid 'IoT24X'

To address FS3904 I think the MACs are required (still??), at least for me the following

/etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'
	option country 'CA'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'aaaaaaaa'
	option ssid 'TuTwo320'
	option macaddr '...:b1'
	option ieee80211w '2'
	option encryption 'sae'

config wifi-iface 'x2_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'aaaaaaaa'
	option ssid 'TuTwo32x2'
	option macaddr '...:b2'
	option ieee80211w '2'
	option encryption 'sae'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'
	option country 'CA'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'aaaaaaaa'
	option ssid 'TuTu32'
	option macaddr '...:b3'
	option ieee80211w '2'
	option encryption 'sae'

config wifi-iface 'x2_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key 'aaaaaaaa'
	option ssid 'TuTu32x2'
	option macaddr '...:b4'
	option ieee80211w '2'
	option encryption 'sae'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '12'
	option band '2g'
	option htmode 'HT20'
	option country 'CA'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'Tu12'
	option key 'aaaaaaaa'
	option encryption 'psk2+ccmp'
	option macaddr '...:b5'

brings up all radios without issue on a rango; I'm on master. Also check CC's are in agreement in your environs.

I have 2 WRT3200ACM "Rango"s and a WRT1900ACv2 "Cobra" plus a MR8300.
The 2 Rangos fail unless the "option macaddr" lines are removed.
Both are on DSA Switch Architecture.

The WRT1900v2 "Cobra" does NOT need the "option macaddr" lines removed to operate properly and is built with DSA Switch Architecture incorporated in 21.02.0.

Both Rango and Cobra use the same basic mvebu |cortexa9 target builds.

The MR8300 does not need the lines deleted to function properly but it is built on
ipq40xx |generic.

It seems to only be a bug in the Rango configuration.

I'm still test driving the Rango to see if anything wireless fails. But I don't really know what the symptoms for MAC confusion might be.

Yes, but it is required on every wifi_iface on a radio, which from my read of your original config was not the case. Seem to recollect that the unique BSSIDs also offered an assist on DSA config / setup.

I had no success using unique BSSID's on trials early on although.... you are correct that there was not a MAC option line in the secondary (subnetwork, additional network) config data.

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xxxxxxxx'
	option network 'lan'
	option ssid 'IoT24X'
	option disabled '1'

I wonder if that is the original error?

But neither does the config in the WRT1900ACv2 cobra have a MAC optionaddr call
in the secondary (subnetwork, addtional network) either and it operates properly.

WRT1900ACv2 cobra config:

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'IoT24'
	option encryption 'psk2'
	option wmm '0'
	option key 'xxxxxxxx'
	option network 'lan'

It seems to keep pointing back to Rango only.