WRT3200ACM 5GHz WiFi drops (fixed)

I'm running the latest stable build:
LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
and I'm seeing the 5Ghz WiFi drop out for about 10 seconds, happening as often as a couple times per hour. I don't see anything notable in the logs.

I've also tried updating to the later mwlwifi drivers, now:

but if anything, it's gotten worse.
Suggestions? Thanks!

/etc/config/network -> https://pastebin.com/gPKE6xSf
/etc/config/wireless -> https://pastebin.com/cegv2kn6

cat /etc/config/network

cat /etc/config/wireless

Make sure to obscure the "option key" value(s) in the wireless config results before posting.

Just to try to find the cause, add the following line in the config wifi-iface 'default_radio0' section:

option wpa_group_rekey 0

Added to my original post (pastebin). Thanks.

OK, added and reboot. Anything I should be looking for in the logs?

@gwr If it works, you should not be seeing the rekeying messages in the logs; or you could just use it for some time and see if the problem happens again.

From posts on the DD-WRT forums and the Linksys forums, it appears that due to widespread wireless issues with this router, Linksys has started replacing them.

You may want to contact Linksys Support for more information.

OK, but I'd assume that the first thing they'd ask me to do is load their firmware, which is of no use to me becase it can't run the three networks I have configured on LEDE (one via OpenVPN for some "work" stuff). Am I wrong?

OK, here's my system log from 9am on...
https://pastebin.com/S7YgWghs

Right at about 10:22 I noticed that the WiFi on my laptop was not working.
The indicator shows that it has signal, but no traffic moves.
Running "ping 192.168.1.1" got no response for about a minute.
Then suddenly ping started working again and everything looked OK.

See any clues in the syslog about what might be wrong?

Actually, it looks like the 5GHz radio is inoperative now.
It shows up the list of stations, but doesn't move traffic.

Thanks!

Should I have added that option to both radios?

What is the MAC address of the wireless interface from the device that failed?

Actually, I think both radios may be going deaf when this happens.
I switched over to XXX2 (the 2.4GHz one wlan1)
and still see drop outs. The 5GHz is the once I've
been using most of the time , which is wlan0.

wlan0 Link encap:Ethernet HWaddr 60:38:E0:B6:1F:22
inet6 addr: fe80::6238:e0ff:feb6:1f22/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2877781 errors:0 dropped:0 overruns:0 frame:0
TX packets:5601562 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:479514605 (457.2 MiB) TX bytes:6636998159 (6.1 GiB)

wlan1 Link encap:Ethernet HWaddr 60:38:E0:B6:1F:21
inet6 addr: fe80::6238:e0ff:feb6:1f21/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:761983 errors:0 dropped:0 overruns:0 frame:0
TX packets:1981843 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:102377591 (97.6 MiB) TX bytes:1951534457 (1.8 GiB)

According to the WRT3200ACM page...

Open source ready with OpenWrt® and DD-WRT®

LEDE = OpenWrt

Contact them and ask.

@gwr I meant the MAC address for the client device: I need to identify it in the logs.

Ah, OK. My laptop WiFi is: 84:3A:4B:20:FC:F6

My two cents:

  • There are still "WPA: group key handshake completed (RSN)" messages in your logs. Looks like the "wpa_group_rekey" option is being ignored. However, there are no messages about rekeying around the time of the incident, so I would discard that.
  • There are some DHCPINFORM messages, that should only happen if the client has been given an IP address manually or by a device different than the router; is that the case? It could be relevant, as one of these messages happens around the time of the incident.

The remaining "group key handshake" messages are for radio1 (the 2.4GHz one).
Per your earlier advice, I added wpa_group_rekey 0 only on radio0,
I've since added it to radio1 as well. Let see how that goes...

BTW, reading up on that option, and some suggest setting it to a
non-zero but longer interval, like a day? Would that be better?
Can one schedule rekey to happen only at 3am every day?
(so the gamers in the house don't keep hollering at me? :slight_smile:

I'm having this same issue. Drives me crazy.

It looks like setting "option wpa_group_rekey 0" on both radios has fixed our drop outs.
Thanks very much for the suggestions.

Hi there, I know this is an old thread but I'm facing issues where my WRT3200ACM keeps dropping wifi signals randomly... Everytime this happens, this message appears in the log:

daemon.notice hostapd: wlan0: STA-OPMODE-N_SS-CHANGED

Anything related? I tried the "option wpa_group_rekey 0" but no luck.. Thanks!