WRT1900ACS WAN switch speed is not being set to 1000baseT


I recently purchased a used WRT1900ACSv2 to improve throughput on my network. The router it is replacing was also a gigabit router (wndr3800) but the I wasn't getting good throughput. My hardware setup is as follows:

[WRT1900ACSv2] <--> [R6700v3 running ddwrt] <--> FIOS

The R6700v3 is also a gigabit router. When I connected the old wndr3800 to the R6700v3, the switch page on the wndr3800 showed a physical speed of 1000baseT. When I plugged the new WRT1900ACS into the R6700v3, it is only showing 100baseT instead of 1000baseT.

I'm using a cat6 cable from the internet (wan) port of the WRT1900ACS to the lan port of the R6700v3 and it is the same cable that worked fine previously. These readings, by the way, are with a fresh install of openwrt 19.07.5. I've tried switching ports on the R6700v3 and no difference. To be honest, I'm at my wits end and don't know if it's a problem with the router itself or some setting on the firmware.

Thank you!

I'm starting to think it's a hardware issue on the router. I tried switching the wan port to one of the lan ports and depending which port I pick, I get the desired 1000baseT link. The problem ports are: lan1, lan3 and wan. lan2 and lan4 are at gigabit speeds.

This router supports dual firmware. If you didn't flash OpenWrt on the secondary partition, you can boot the stock firmware from it and verify if it is indeed a hardware or firmware problem.

1 Like

Hi @trendy ,

The stock linksys firmware is behaving the same as openwrt. I guess that seals it.

1 Like