WRT1900ACS v2 - Wifi client mode slow down speed

Hi
Have a wrt1900acs v2 running latest David c502 build. I was able to easily connect to my isp modem in wifi 5ghz client mode and everything works, except only the download speed is slow. I get 80mbit up/down from my isp, and that's what I get on my phone connected to 5ghz, but the router gets only gives 25mbit down, yet it gets almost full speed (78mbit) up on speedtest.

I had the router running linksys firmware before and was getting full speeds up and down, but it kept randomly disconnecting so I switched to openwrt.

Appreciate some help..

I don't know what is specific to Davidc builds. But there is a thread for this builds where you should ask and/or look out if others have the same problems/results:


If you want to verify if it is an issue in general or Davidc specific try out the vanilla OpenWrt to find it out.

Just flashed the vanilla build and got the same result. It's really frustrating because there are no errors that could lead me to the problem. The connection is stable, upload speed is perfect, but the download speed is poor. Really weird..

after trying several builds, i figured why not try ddwrt. at first i was getting the same result, but then i switched network type to "N only" (still using 5Ghz), and that solved the issue, full speed up and down..

since i prefer openwrt i went back and tried to do the same, but unfortunately it didn't work. tried changing everything one at a time but nothing worked..

since it worked fine on ddwrt given the above solution, i was wondering if someone could shed some light on how i may be able to overcome this and come back to openwrt..!

1 Like

@jaikat, what ddwrt build did you use?

I have had problems with DNS resolution on my WRT1900AC for both dd-wrt and openvpn.

It is frustrating.