WRT1900ACS - Losing connectivity to wireless Canon printer


First post here, I'm running LEDE Reboot 17.01.4 on a Linksys WRT1900ACS. I've noticed recently that the Canon MG5500 printer that I have connect to the Wifi randomly stops allowing me to print from the laptop that is also on Wifi. The printer is assigned a static IP address via DHCP on the Linksys as are the other various hosts on the Wifi (none of which are experiencing issues).

On further investigation I found that while the printer doesn't respond to pings from my laptop, if I login to the Linksys I am able to ping the printer from there.

I tried looking at various logs on the router but don't see anything obvious. I resolved it by rebooting the router but obviously this is just a workaround.

I am relatively new to LEDE and would appreciate any pointers on how I can find the root cause of this.


I would start by installing the updated wifi drivers for that device; go to the post below, and install the .IPK files from the last announcement:

Two ideas for you:

  • Slightly different, but I experienced this with my wifi-connected Samsung printer: its sleep-mode affects also wifi, so after a while the printer loses connectivity via wifi. That can be changed in printer's admin menu, so that the wifi network capability stays active also in the sleep mode. Sounds a bit different than your problem (as you can still ping the printer from the router itself), but your problem might be something similar.
  • I have seen mentioned that some printers do not like old WPA encryption and prefer WPA2, so that using WPA would lead into wifi connectivity loss sooner or later.

Make also sure that you have the newest firmware in the printer itself.

You being able to ping from router itself but not from a client PC might also hint toward

  • DNS/DHCP problem (if you are pinging with name instead of IP)
  • your firewall blocking the connection somehow, but that should not happen inside LAN
  • some kind of wifi isolation setting that prevents wifi devices from seeing each other.

Thanks for the replies.

I've checked the printer is on the latest firmware and it is current.

I did some more investigation and as I said before I could not ping the printer from my laptop (on wifi) and but could ping it from the LEDE router itself.

i checked the ARP table on the laptop and there wasn't an entry for the printer which is on a static IP fixed via DHCP on the LEDE router.

I wasn't able to check the ARP cache on the LEDE router but the fact I could ping the printer from there means it must of had a MAC entry on the router for the printer.

As a check I installed "arp-scan" on the LEDE router and ran it for the wireless interface and it came back with an entry for the printer.

After this when I checked the ARP cache on my laptop it came back with an entry and I was able to ping the printer from the laptop.

I believe running the arp-scan tool caused a refresh of the arp table on the laptop but I'm not clear why this is not happening automatically as it is for other hosts. The only difference I can see is the autosleep mode on the printer that allows it to wake when you attempt to print to it.

I haven't had a chance to update the wifi drivers as suggested and want to do further invesigation but thought it would be worth posting an update to see if anyone has any suggestions for identifying the root cause.


I've had this problem on this router over all the LEDE releases. Power cycling the router (poweroff command followed by a power cycle) doesn't seem to fix it but a reboot does.

I've tried updating the wireless drivers in the past and that doesn't help. I've not been able to find a permanent fix.

I had this problem. The reason was 802.11w Management Frame Protection. My pc could not even ping the printer when that setting was on.

1 Like