WRT1900ACS back to stock firmware

Hello, i need to revert stock firmware on my router,, i 'm totally lost on the string i have to put in putty for flashing , i m trying to sort it out since 4 days ago , always ending up with an error .
I followed https://openwrt.org/toh/linksys/linksys_wrt1900acs#return_to_stock_firmware but to be honest
pscp -scp` -r -i "C:\OpenWrt.ppk" -2 pscp -scp -P 22 "D:\Path\To\Firmware.img" root@
does make little sense to me ...sorry,,total newbie

Any help please?

I'm doing the same sort of thing. This is what I've learned in the last week. You can get to the other image (typically last known good) on your system by powering down and do the following three times:

Power up until the left most LED comes on and then I let it flash a couple of times before powering back off again.

After the third time I've been staying down, pulling the power jack and turning the power switch on and letting it rest for 30 seconds or so like that to discharge caps. Then apply power. It should come back up with the last good configuration. I'm not sure that discharging the caps is necessary.

That's been working 100% of the time for me.

I went to the stock image by simply by downloading the image from LinkSys (in my case FW_WRT1900ACSV2_2.0.2.188405_prod.img) then loading that via LuCI.

I got the image but I wasn't really any better off with it.

I'll probably start a topic with my own issue in a bit, right after I reach the end of the Internet with Google.

Good luck!


I;'m able to switch on other partition,just need to put stock where openwrt is..

I've read (I've been doing a lot of reading this last week) that you cannot write an image on the currently active partition. Only the other partition, which makes sense to me!.


So how can i cancel or revert openwrt from partition?

That will probably need to be answered by someone with more than one week's worth of experience with OpenWRT. Sorry.


By flashing from the other partition.
Both OpenWrt and OEM firmware always flashes the other, while keeping the current one as fallback option.

If you can switch partitions, simply switch to the other one still running OEM, and flash a new OEM firmware. That will overwrite the OpenWrt image.
(But this only works if you still have OEM now in the other partition)

For downloading the OEM firmware, you can simply download it with wget directly from the router console. No need to use any PC and then scp.

spent another couple of hours working on it , but doesn't work, tried to flash oem on second partition but always reboot on first partition i even tried with ddwrt and also not working , only thing working is Shelby , i also tried to flash a img with luci but i get this error ,

"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

Is there any way can i reset completely the 2 partitions in the router ?

Probably the easiest way is to update OpenWrt to 19.07.0-r2 , and force upgrade to Linksys OEM image. I tested righ now on the WRT1900ACS-v2

It needs to be forced.

You need Terminal on Mac or Ubuntu or Putty on Windows. Login to your router by typing the following:

ssh root@

Then you need to download the firmware from Linksys directly, so run one of these depending on whether you're V1 or V2:
for WRT1900ACS V1

cd /tmp && opkg update && opkg install wget && wget https://downloads.linksys.com/downloads/firmware/FW_WRT1900ACS_1.0.3.187766_prod.img


cd /tmp && opkg update && opkg install wget && wget https://downloads.linksys.com/downloads/firmware/FW_WRT1900ACSV2_2.0.2.188405_prod.img

Finally, run this command to force it to upgrade

cd /tmp && sysupgrade -F -n -v FW_WRT1900ACS_1.0.3.187766_prod.img


cd /tmp && sysupgrade -F -n -v FW_WRT1900ACSV2_2.0.2.188405_prod.img

Obviously just pay attention to whether it's V1 or V2 and it should work very smoothly after flashing the final command. Hope it works for you.

i get this error on downloading firmware
"https support not compiled in" :confused:

Download the files to your computer first. Then cd into whatever folder they're in on your PC.
You don't need to connect via SSH first for this.
scp FW_WRT1900ACS_1.0.3.187766_prod.img root@
or if V2

scp FW_WRT1900ACSV2_2.0.2.188405_prod.img root@

Then ssh into the router and run the last step of the commands above with sysupgrade in it. The problem is curl doesn't support HTTPS in the way it's currently installed. This gets around that.

You can simply change https://... -> http://...

1 Like

I'm so frustrated...I put the file everywhere,,,but putty gives me an error "no such a file or directory"...

On the device

cd /tmp
wget image
#optional check for the paranoid sha256sum image
sysupgrade -F -n image

There are many examples to be found by searching this forum

1 Like