WRT1200AC Random Reboots on 18.06.0, r7188-b0b5c64c22


I'm running 18.06.0, r7188-b0b5c64c22 (with the latest updates installed). I've been experiencing random reboots since going to the 18.x release candidates. I didn't file a bug or post because I assumed it would be worked out.

The reboots would occur from every 18-24 hours to as often as 1-2 hours.

I've gone through and slowly disabled services and I believe it's tied to me enabling SQM. I disabled SQM and my router hasn't rebooted in 48 hours, it also ran for 24 hours before that without a reboot until we had a power blip. I set up remote logging and never saw any events related to the reboot, I would see normal DHCP/WLAN log entries then a message that remote logging had reconnected after the reboot.

Is anyone else reporting a problem with SQM? I'd really like to re-enable SQM, I suffer from pretty bad bufferbloat (500+ms) without.


My WRT3200ACM devices are very stable but they're on master branch and a few modifications but they're not running SQM. I do have other devices running SQM which are stable (16d+) but they're also using the master branch with -O2 instead of -Os mainly to avoid compilation bugs/quirks but in general performance should be slightly better too. Might be worth giving it a try.

SQM itself has no binary components. It just sets tc rules and enables various alternative "qdisc" QoS packet schedules according to your config settings (cake, fq_codel, etc.)

Have you tested with both cake and simple (fq_codel) QoS options in SQM?
Or just with one qdisc?

I'm running a build i made about a week ago on my wrt1200 (OpenWrt SNAPSHOT r7569-4c1aa64) with sqm enabled and haven't had any rebooting problems, I have lost connection a couple of times under heavy load, but no rebooting. If you have the time you might try a fresh default build with no other extra packages except for sqm and run that for a day or two to see if the problem persists.

I thought there were kernel modules involved.

qdisc packet schedulers are kernel modules. cake, fq_codel, hfsc etc.

You have one of them selected in your SQM config.
If you are crashing with cake/cake, try simple/fq_codel (or vice versa).

1 Like

I've tried with both cake and simple. Just as a sanity check last night, I re-activated SQM and the router rebooted within a couple of hours, after having been up for a couple of days.

I moved over to David's builds for the WRT1200AC (Lede SNAPSHOT, r7581-7880a6f7fe) and I'm seeing the same thing.

I may go back to the 17.x builds.