WRT 3200ACM Stability and Wireless Problems with 21.02

I tried upgrading my WRT3200ACM from 19.07 to 21.02 and I ran into a few issues. First I got the warning that my config wouldn't be carried forward. Fair enough, but upon accessing the router post-upgrade I noticed that it did indeed try to keep some of my settings. After a couple hours of fighting with it trying to figure out why the web interface would slowly stop responding and wifi connections would stop responding, I decided to do a "reset" to delete any lingering config files that might be screwing with it and start from scratch, but alas, the issues persisted. Upon downgrading back to 19.07 and restoring my backup config everything is peachy again.

My issues with 21.02 included:

  • Wireless connections would work at first, but then stop responding after a few minutes.
  • The web interface would work fine at first, and then eventually stop responding, even though ethernet clients could still access the internet and SSH logins would continue to work properly.
1 Like

Apparently, there is a long list of issues with 21.02.0 on WRT3200ACM and WRT32X. I tried 21.02.0 and quickly abandoned it and reverted back to 19.07.8


I hope they'll be able to sort out the problems. Not particularly fond of having to get rid of this router after getting it only a little over a year ago. I also don't want to stay on a old release forever.

Not urgent to upgrade until there is a major security vulnerability discovered in 19.07.8


Hopefully it stays that way.

Same issues which I noticed on a WRT32X.

1 Like

That is a well known mwlwifi issue when WPA3-SAE or WPA2-PSK/WPA3-SAE Mixed Mode are used, best WIFI security supported by the mwlwifi driver is WPA2 PSK , using that setting with 21.02 since yesterday with no issues.


Other than intermittent wifi issue what else is on this long list.

@jeff1 , see thread re wpa3. I did not test beyond testing connectivity,but here were some changes to master that have changed things; but as reported in that thread sae mixed is still borked.

Same with WRT1900ACS v2...

I did try to upgrade to WPA3, and I noticed that the network I left on WPA2 would continue working fine after the WPA3 one would die. I may retry the upgrade again this evening and see if leaving it at WPA2 solves the problem, but I believe I was still having issues with the web interface freezing because after a few minutes of tweaking settings, downgrading it to WPA2 , etc. I'd have to go hard reset the router to get the web interface back because it would stop responding even to clients connected via Ethernet, although the Ethernet clients could still access the internet.

I may just leave it alone though. 19.07.8 works great and unless there's any meaningful security vulnerabilities or plans to stop issuing security updates or package updates, I'd rather not go screwing with it.

I have a WRT1900ACS v1 that I haven't upgraded to 21.02 yet. Given how many issues there are with it, I am starting to think of just tossing it away and getting something else.

On the previous OpenWRT-version, I have had to disable WiFi AMSDU or else it'd randomly drop some connections and it'd have quite bad network latency, but with 21.02, it seems one can't enable management-frame protection or WPA3, either.

1 Like

After coming back from mixed WPA2/WPA3 to WPA2, please remember to also disable 802.11w (management frame protection) which is the main problem in the WPA3 lockups. Setting 802.11w to enabled or optional is the path to the non-responding state...


I think this is only an issue with 88W8964 devices, at least for me sae mixed is running fine on a mamba.

My note about WPA3 above is only relevant to master as the commits are not in 21.02.

I'm not sure if this is the best place to report, but I noticed that:

  • I can't create an unencrypted guest network on radio1. If I try then my other WPA2 PSK 11n network never comes up. Actually, it looks like radio1 never comes up. If I only use 1 SSID with radio1 then it seems to work okay.
  • radio0 in 11a mode seems to offer a 160MHz width but the radio never comes up if I try it. It works okay with 80MHz width.

Ensure each wifi_iface stanza contains option macaddr, fails as noted when only one (default) stanza has the option.

1 Like

Thanks for the tip. Do I want the same macaddr for both wifi_iface?

No, increment / decrement, example, some people remove the one MAC generated by the setup script, but see my note in that thread.

1 Like

For my wifi I moved to using unifi UAP-AC units. They are not without its issues, but it did improve my house coverage massively . Putting one on the ceiling on the first floor was a major step forward. Wooden floor between downstairs and first floor and plasterboard walls on first floor enables the AP to create a good coverage of the whole house that cold never be achieved with the WRTXXACM unit.

I noticed another issue yesterday. Two out of three Android OnePlus phones cannot keep connection to the 5GHz network anymore. They have no trouble with the 2.4GHz network. This is not a showstopper, but it would be nice to understand the issue. The phones worked fine with 5GHz prior to the upgrade. One phone still works fine with the 5GHz network.


Same here, even when WRT 3200ACM have no 802.11w enabled and using normal WPA2-PSK, I get intermittent Wifi. I also tried changing WPA2 to WPA3/WPA2 mixed mode and it stopped being intermittent to not working at all. I had to change to my old firmware partition with 19.07 installed.