Wrt 1900acs on 5GHz Solved

Hi there, i am having a minor issue with the 5Ghz band on my router. I was once able to connect to the both 5 and 2.4Ghz on my phone. But since flashing lede on my 1900acs i am only able to use the 5Ghz on my laptop computer. As for the 2.4Ghz i can only connect to that with my phone.
I there a solution to this problem? Please help and thank you in advance for your time and help.

What version of OpenWrt?

Probably wrong selected region and/or your devices does not support your used channels?

1 Like


The mwlwifi included OOTB with 17.04 is old and has known issues. You could/should get the latest for that image, or at this juncture start with the latest 18.06 stable, which has a current mwlwifi version.


Okay thanks for the information on that. I have been experiencing some issue.

Thank you guys for all the support. The main issue is resolved. The issue was the channel settings, it was set to auto. I had to change it to channel 149 at which point it started to work. The puzzling part prior to getting it resolved is the fact that once i rebooted my phone, it would connect for a brief second then disappear from the wifi options. Again thanks a lot for all your help and support.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

To be honest i was looking for a way to do so but i cant find a way to do it.

  • Click on the pencil icon beside the title of the thread:


  • Edit the title and click the Check Button.
1 Like

Thanks i thought that there was like a dedicated button for that.