WPS Not working

I am having a problem getting WPS to work on WRT1900ACS v2. I have tried all the following links. an neither are working. I am now on the configuration of the last link provided. Neither my printer nor AV600 powerline connects to the router. The last link succeeds to enable the WPS to work as intended, but still no devices can connect.

  1. https://gist.github.com/alghanmi/4de45337ca517ebe3a56
  2. http://jaredrobinson.com/blog/add-a-camera-via-wps-to-a-lede-openwrt-router/
  3. https://roll.urown.net/router/wps.html
  4. https://volatilesystems.org/wps-setup-on-openwrt.html
  5. https://github.com/Depau/OpenWRT-WPS-Button

Doing this command responds with
wlan0 - 5GHz AP
wlan1 - 2.4GHz AP

hostapd_cli wps_pbc

Selected interface 'wlan0'
hostapd_cli wps_get_status

Selected interface 'wlan0'
PBC Status: Active
Last WPS result: None

How can I solve this?

tested and same problem ...

i search to pass a TV stream provided by my internet provider

I already asked the question and the answer was: the WPS is not secure

Yet I have a box , relays WIFi and a TV box that have been provided by my BIG provider who is Orange in France with WPS !!

As i have not found solution i use WDS as this:
BOX internet -LAN- WR1200JS in WDS master -WIFI- another WR1200JS in WDS slave -LAN- TV stream box

It would be better with only a WR1200JS as:
BOX internet -WIFI- WR1200JS in relay & WPS mode -LAN- TV stream box

I use hostapd_cli -i 2G_ap_guest wps_pbc to "press the button" and hostapd_cli -i 2G_ap_guest wps_cancel to cancel. The WiFi network is called 2G_ap_guest and is for guests.

I have the same router and the same problem.

I have hostapd-utils and wpad-openssl installed

Using the commands hostapd_cli -i wlan1 wps_pbc and hostapd_cli -i wlan1 wps_cancel don't work

I temporarily switched back to the stock Linksys firmware and the WPS works perfectly on there