Wpad-basic update problem

Hello everyone, when I update wpad-basic today it gives me a conflict with hostapd, which is not installed in the system, I don't know how I can fix it

You could also change wpad-basic to hostapd, they have the same dependencies.
How could I do it: uninstall wpad-basic with --force-depends and then install hostapd?
Reboot and do I have to reconfigure the access points?

I would

  1. create a backup (to be on the safe side :slight_smile: )
  2. hostapd info looks strange, as it is shown 2 times, v5 as unknown, v4 as install. Therefore I would remove hostapd with force option, remove wpad-basic with force and then install wpad-basic again.
    If that does not fix the problem, I would consider resetting the system, installing/upgrading the packages you need and restoring the config backup.

The wireless config should not be touched by uninstalling packages. At least after my sysupgrade to 19.07.6 I had to uninstall wpad-basic and install wpad (as I am using wpa2/enterprise). My wireless config was not touched by this and worked fine.

I understand, thanks for answering, the hostapd package is not installed, I only have hostapd-common as it depends on wpad-basic so I'm a bit confused, I'm afraid of breaking the system

It is already solved I have uninstalled wpad-basic and I have installed hostapd, then I have restarted and everything is fine without having to reconfigure the access points

Well in the end I have again uninstalled hostapd, and I have installed wpad as you told me

Little misunderstanding: You only need wpad-basic, I suppose.

What I don't understand is that in opkg info hostapd appears as not installed 2019-08-08-ca8c2bd2-5, and if the previous version 2019-08-08-ca8c2bd2-4.
That has me disoriented

I absolutely agree. That seems to be an inconsistency.

I hope it is gone, like in my system:

root@WLAN-Router-3:~# opkg status hostapd
root@WLAN-Router-3:~# opkg info hostapd
Package: hostapd
Version: 2019-08-08-ca8c2bd2-5
Depends: libc, libnl-tiny, hostapd-common, libubus20191227
Status: unknown ok not-installed
Section: net
Architecture: mips_24kc
Size: 290770
Filename: hostapd_2019-08-08-ca8c2bd2-5_mips_24kc.ipk
Description: This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.