WPA2-PSK/WPA3-SAE Mixed mode

Hi !

If i set my APs wireless security to WPA2-PSK/WPA3-SAE Mixed mode, some older devices will not "see" (and therefore cant login) any wifi (gn/ac => tp-link archer c7v2).
On newer devices (like my mobile) evrything is fine...

Ciao Gerd

Yes, this is consistent with most people’s experience. Mixed mode just doesn’t work that well (or at all) with some devices. This, you may need to have wpa2 exclusively if your equipment doesn’t support wpa3.


I have a "smart" thermostat that cannot see my mixed mode network, but it can connect to it if I manually enter the SSID/password. Have you tried that?

For reference:

config wifi-iface 'wifinet4'
  option device 'radio1'
  option mode 'ap'
  option network 'iot'
  option ssid 'lightsout'
  option key 'xxx'
  option encryption 'sae-mixed'
  option dtim_period '3'
  option ieee80211w '1'
  option wpa_disable_eapol_key_retries '1'

Yes.. but no success... the wifi which can't see the wifi is an Intel AC 3160
I tried several Windows drivers

Ciao Gerd

Best practice here is to set up a separate WPA2 and WPA3 SSID. AFAIK the performance penalty is minimal.

1 Like

Like i did now... one SSID for each.. and the WPA2 i made invisible

Ciao Gerd

Hi !
at the end i can see on the incompatible Device now the wpa3 network, but when i try to login it say "cannot log into network"
So i have to connect to the hidden wpa2 network

Ciao Gerd

For my linux client with old Intel 6502 wifi, router using WPA2/WPA3 mixed mode, the linux driver has issue that it couldn't fallback to WPA2, however using nmcli to force it WPA2 it works OK, I don't need to change anything on router.