WoL, ethtool and reboot problem


#1

Hello.
I have problems with persist ethtool settings through reboot.
I'm using 17.01.3 on Geode host with single realtek 8139 nic.
So I have br-lan, eth0 and lo interfaces in system.
In BIOS I've checked that "PME Events Wake Up" is "Enabled" but ethtool eth0 still show that Wake-on is d (disabled).
I can execute in shell command 'ethtool -s eth0 wol g' to set it to be able to wake up, but ofc it will be resetted after reboot, so I need it to persist somehow.

There is where problem start:

  1. I add to rc.local 'ethtool -s eth0 wol g' - no effect after boot, Wake-on is 'd'.
  2. Searching forum i've found How to make ethtool setting persistent on br-lan, did it - no effect after boot, Wake-on is 'd'.

Can someone help please?

Upd: Adding "sleep 15" to 1st variant is doing job right. Looks like rc.local execute script (if it's without this delay) too early (before eth0 is ready) or stuff.

But why 2nd variant which is kinda like specially designed to work when interface is up - is not working for me... =(


#2

hi. try to use whole path for ethtool in rc.local. For example /usr/sbin/ethtool -s eth0 wol g

EDIT: OK. Too late :smiley: and wrong :smiley: