WNDR4700 Support for USB3

I was excited to find WNDR4700 is supported, however after installing "lede-17.01.4-apm821xx-nand-WNDR4700-squashfs-factory.img" I found the USB3 ports do not work. This is a problem as have a USB drive which I use for dlna.

The forums showed me that I need to install "uPD72020x-firmware_2_powerpc_464fp.ipk" but none of the links work and it cannot be found on the internet.

Does any have a copy of "uPD72020x-firmware_2_powerpc_464fp.ipk" ?

Alternatively, is there another way to active the USB3 ports? I've tried copying K2013080.mem to /lib/firmware and rebooting modem, but no luck. If I run dmesg, I get the error message "xhci_hcd 0000:45:00.0: firmware failed to load (-2)".

Have you tried USB 2.0 and plain 1.0 devices?

The product sheet for the CPU says USB 2.0.

EDIT: FROM WIKIDEVI https://wikidevi.com/wiki/Netgear_WNDR4700:

Additional chips
USB3.0 Host Controller;Renasas;D720202;;1;

Patching this in would solve the issue.
https://patchwork.kernel.org/patch/9195761/

Also,including the firmware with a dummy app like ipq-wifi would be great

Hi robimarko - this looks like it would work!

Sorry to ask but could you give me guidance on how to apply the patch?

Easiest would be to have openwrt patch in all of its stuff and then edit that and create a patch

https://github.com/kdm6389/singlefile/blob/master/lib/firmware/uPD72020x-firmware_2_powerpc_464fp.ipk

1 Like