WNDR4700 ip6 wan not working

I have eth1 (USB RNDIS 4G-LTE 50Mbps Modem) connected to WNDR4700. When I connet this eth1 with my pc directly it provide me ipv4 and ipv6 address.

[ eth1==>WNDR4700==>MANY-PC ]

My question is:

  1. Is my eth1 has assigned any ipv6 address for my WNR4700.
  2. If WNDR4700 is assigning to its client.
  3. The good thing about eth1 is it provide global unique ipv6 address to its client.

Help to setup ipv4/ivp6 environment seamlessly, or "dont break your head on ipv6 exiting configuration is good as long it work", any help??? If you need more information, let me know.

the defaults work for most people ok, if the upstream (ISP, modem, whatever) provides full IPv6 support. You have apparently created a new wan interface, so you will likely need to adjust some settings accordingly.

You should show the /etc/config/network and /etc/config/dhcp instead of the screenshot. Also the current address status from "ifconfig" output should tell you if there ip a routable ipv6 address for the router.

https://lede-project.org/docs/user-guide/basic-ipv6-configuration

Ps. It is possible that your modem does not allow for prefix delegation, so an individual PC may get a working address, but router wants a full /64 prefix and does not get it. If that is the case, you may need to set the ipv6 config for relaying as explained in the wiki .

# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'



#eof

# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdec:5a77:b55d::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.3.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option auto '0'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 3 2 1 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'RNDIS'
	option proto 'dhcp'
	option ifname 'eth1'
	option hostname 'WNDR4700'

config interface 'RNDIS6'
	option proto 'dhcpv6'
	option ifname 'eth1'
	option reqaddress 'try'
	option reqprefix 'auto'
	option auto '0'

config interface 'MM'
	option proto 'dhcp'
	option ifname 'usb0'

root@WNDR4700:~#
root@WNDR4700:~# ifconfig 
br-lan    Link encap:Ethernet  HWaddr 20:XX:B1:XX:XZ:28  
      inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
      inet6 addr: fdec:2b22:3456::1/60 Scope:Global
      inet6 addr: fe70::44b6:2bcc:cc11:be18/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:88694 errors:0 dropped:0 overruns:0 frame:0
      TX packets:91290 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:29014583 (27.6 MiB)  TX bytes:53373911 (50.9 MiB)

eth0      Link encap:Ethernet  HWaddr 20:XX:B1:XX:XZ:28  
      inet6 addr: fe70::44b6:2bcc:cc11:be18/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:5093 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:720442 (703.5 KiB)
      Interrupt:43 

eth0.1    Link encap:Ethernet  HWaddr 20:XX:B1:XX:XZ:28  
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:5077 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:697625 (681.2 KiB)

eth1      Link encap:Ethernet  HWaddr FC:XY:ZY:YY:KL:06  
      inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::fede:56ff:feff:106/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:87929 errors:11 dropped:0 overruns:0 frame:11
      TX packets:74398 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:49255669 (46.9 MiB)  TX bytes:31572289 (30.1 MiB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:10 errors:0 dropped:0 overruns:0 frame:0
      TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:1876 (1.8 KiB)  TX bytes:1876 (1.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 20:XX:B1:XX:XZ:28  
      inet6 addr: fe70::44b6:2bcc:cc11:be18/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:88686 errors:0 dropped:0 overruns:0 frame:0
      TX packets:94870 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:30256139 (28.8 MiB)  TX bytes:56521576 (53.9 MiB)

wlan1     Link encap:Ethernet  HWaddr 20:XX:B1:XX:XZ:2A  
      inet6 addr: fe70::44b6:2bcc:cc11:be1a/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:4904 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:760215 (742.3 KiB)

root@WNDR4700:~#

I have altered ifconfig result for hiding MAC, because i am copying other people. I dont know that I should share my MAC on public or not.

Reading https://lede-project.org/docs/user-guide/basic-ipv6-configuration

Looks like you disabling the ipv6 address by dhcpv6, as you have "auto 0" there (so that the interface stays down). You should remove that auto 0 setting or manually do "ifup RNDIS6" to bring the interface up.

The reqaddress and reqprefix are usually unnecessary.

ok,

this is direct connection with PC [ eth1 ==> PC1 ], this is just for information

user@MYLinux:~$ ifconfig 
enp1s0f0  Link encap:Ethernet  HWaddr 20:12:34:87:aa:f7  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18 

enxfcde56ff0106 Link encap:Ethernet  HWaddr fc:ed:65:aa:10:26  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7bb6:a0b4:11a6:873c/64 Scope:Link
          inet6 addr: 2405:205:a0b6:a0b4:11e:5f60:9f42:cef2/64 Scope:Global
          inet6 addr: 2405:2b6:a0b4:110d:d408:dfc0:4012:a6bc/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:687 errors:0 dropped:0 overruns:0 frame:0
          TX packets:882 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:117544 (117.5 KB)  TX bytes:159443 (159.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2172 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2172 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:170173 (170.1 KB)  TX bytes:170173 (170.1 KB)

I am living in India with more than 1.38 billion people, they all are getting smartphone, So I want to tune up with ipv6.

this is wrong, there is another layer that is
[ Modem{wan=>eth1}==>WNDR4700{wan+wan6 ==> lan+wifi}==>MANY-PC ]

Is there anyway to test my ipv4/ ipv6 connectivity for my application {android, chrome, firefox, ubuntu, windows xp and 10}

What is this do I have tweak this, or its ok, don't touch it.