WNDR3700v4 flash not used fully

Happy new year all!

I have this device wndr3700v4. I know that it has nand flash and that for safety reasons to sister board wndr4300 it was decided to divide it's storage. I have asked this question previously here and there was a patch which fixed this problem for my device and i could use whole 128 MB of flash. Here is that thread LEDE on WNDR3700v4 (available flash size)
Since then i frequently build firmware to include this and 2 other patches and software that i want my router to have. Recently this router switched from ar71xxx to ath79. When it built i had 2 firmwares one build ar71xx and other ath79. To not have any problems switching i first flashed ar71xx build and then ath79 without saving settings. I quickly set up router from backed up settings and it worked. But once it froze. I rebooted and it works now good. I wanted to install program and suddenly saw that /dev/root is 100% used. I remembered this patch and checked. It seems on ath79 it's not working. I had patched legacy.mk file. Can anyone help me achieve the same result on ath79 which i had on ar71xx using this patch?


You have to modify the device tree to change the mtd partition sizes.

Here is the related device tree part which does define the size of your root partition:

The following property in the node ubipart1: partition@2000000 does define the start address (0x2000000) and the size (0x6000000).

reg = <0x2000000 0x6000000>;

According to the size, you should have already 96 MB for your root partition.
So no need to patch here anything!

Sorry, my assumption was wrong...
According to the following node you should have 119 MB for your root partition as there are two mtd partitions that are merged into one partition with the mtd-concat driver:

1 Like

LOL I was wrong. I do have all of my routers nand storage available. /dev/root is 100% used and mounted on /rom, but it's always 100% used no matter what. The other part is /overlay which is 87.2 MB for me currently, because my firmware is prety large.

Please close the thread. Or even better delete it to not bring confusion. Everything works as it should no need for patch or anything on ath79 builds.

Then you can hit the solved/solution button on my post above... This will auto close the thread after some time and marks it as solved.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.