WMM mode leads to dropped SSH packets?

I'm running two OpenWrt devices: One as a simple home router (Mediatek MT7603E), the other as a dumb AP (Mediatek MT7615E).

Everything has been working fine for years, except for SSH connections to certain LAN devices, when connected to the AP's wifi with my Windows 10 Surface Laptop 3.

HTTP connections to the same LAN devices work without issues, the same is true for SSH connections to other LAN devices and WAN devices.

Today, I've finally found the time to troubleshoot this. So the setup is this:

Windows 10 Surface Laptop 3 ==Wifi==> AP ==Ethernet cable==> Router ==Ethernet cable==> SSH device

tcpdump revealed: The Windows 10 Laptop does not receive any TCP reply packets from the SSH device, while those packets are dumped on the AP.

Sometimes, some packets arrive at the laptop and the SSH connection might even be able to establish and authenticate (very slowly). Holding a button in the terminal shows that the connection is slow and the letters only appear with big delays until the connection is finally dropped.

As soon as I disable WMM mode on the AP, everything starts working perfectly.

Connecting to the router's Wifi (with WMM mode enabled), allows connections without issues, too.

What can I do to get rid of this issue? Without WMM, Wifi speed is severly limited, so it's not really an option.

Anyone got any clues? Would love to be able to use WMM and still reach my devices over SSH...

Perhaps you can post your network and wireless configs. I've read over your post a few times personally, but nothing really seems apparent as the culprit causing your issue.

cat /etc/config/network
cat /etc/config/wireless
  • What SSH client software are you using?
  • Do clients running other OSes have an issue?

Did you make any config changes in the meantime?

EDIT:

Also:

So the dumb AP is still configured as a router/firewall?

  • What do you mean by the phrase "those packets are dumped on the AP"?
  • Where was tcpdump ran?

What version of OpenWrt? There were some mediatek problems last year that should be fixed now.

Sorry, I noticed how unclear I was at some points. The issue existed from the first day. With "everything's been running fine" I meant "everything else" as in: I've not noticed any other issues with many different (SSH) connections (WAN) over the years.

I was running the tcpdump on Windows and the AP. I was wondering why the packets even showed up on the AP as they shouldn't have when it's not routing, right? Here's my APs configuration:

/etc/config/network

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'
        option delegate '0'

config interface 'lan6'
        option proto 'dhcpv6'
        option device 'br-lan'
        option reqaddress 'try'
        option reqprefix 'no'
        option delegate '0'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'EN'
        option cell_density '0'
        option channel '11'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option ssid 'xyz'
        option key 'key123'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option country 'EN'
        option cell_density '0'
        option channel '100'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option ssid 'xyz'
        option key 'key123'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

About your question regarding clients: Unfortunately, I don't have other Wifi clients I could try. I'm using PuTTY 0.79 as a SSH client. I will see if I can use a VM to try out a Linux client.

I remember reading the thread you're linking to last year. After reading it, I upgraded from 21.02.3 (which I'm running again now) to 22.03.2. Unfortunately, with 22.03.2 I had the SSH issue even when accessing the AP itself, not only the affected network devices. So I downgraded again.

So from what I understand, this is a driver-specific issue that I will probably not get rid of other than trying different versions of OpenWrt?