WLAN to LAN Bridge problem


I want to use my Wifi on my Router (with openwrt) to connect to an external AP (Photo 1).

  • I tried to make a pseudo bridge between LAN and WAN but it doesn't work.
  • I tried to make a bridge on the Lan as in the photos but it doesn't work.

Note: The Wifi Client connects correctly to the internet but my Lan (on my pc) is not working. I have tried in every way.

This is my interfaces:

overview:

traceroute from openwrt:
traceroute

I have searched the forum. A similar problem has been addressed in this topic.

From the diagrams you have provided, the most obvious problem I see is your 'MY PC' (DESKTOP-8REVTOT ?) is incorrectly configured with local IP of 192.168.2.1 or 192.168.0.211 ?

Did you turn OFF the DHCP server on your relayd openwrt router?

If relayd is working, 'MY PC' and any other devices wired to the OpenWrt router must use an IP address in the subnet 100.92.168.x. It is normally provided by an external DHCP server (not by relayd OpenWrt router)

You have not provided any information about 'External AP'. Is it an ISP wifi router with DHCP server offering addresses in the subnet 100.92.168.x?

If you do require relayd, suggest you review section 9.10 in the 'OpenWrt/LEDE installation guide for HH5A' PDF which describes configuring relayd in more detail
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

Otherwise, if you only wish to share a single IP connection (hotspot?) provided by your 'External AP', 100.92.168.243, then you should not be using a bridged connection with relayd. Consider resetting your openwrt router and just setting up a simple 'wireless client' as described.
https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi
(See also section 9.12 of above PDF guide)
eg. factory default openwrt router will use default 192.168.1.1 LAN IP address, and connected clients will be in subnet 192.168.1.x with netmask 255.255.255.0.

Update: A quick google of WOW FI Fastweb reveals it appears to be a community of residential wifi hotspots. You should not be using relayd bridging imho.

Better reset the router and install travelmate package. It does what you need.

you cannot do that with fastweb, you need nat

Seems from the second picture that bridged in lan is also your wifi that is also client of an other network with different ip .... or you have two different radio? If is just one you don't have to use in your internal but only in wan interface