Wish to use 2013 Intel NUC with i3 processor and dead SSD as access point

Probably some way to do this from the command line on openwrt...since I don't have access to the home router. It is downstairs in the landlords' home. I get no ip address from that command "ip addr show dev eth0" but I do see what looks like a hardware / mac address.

Yes of course ip addr show dev eth0

I rebooted the nuc with reboot now. Hopefully the settings were saved to flash drive. Going to continue trying to find the ip address,

openwrt.lan doesn't work from chrome os browser or firefox, nor does it work from the same browsers on android. The Debian laptop does not connect to WiFi because getting the driver working for the Intel wireless card is problematic there. Thinking...

Because the command you gave me did not give the ip address I wonder if that is indicative of some issue...
Clearly I am not a network expert.

I await further instructions from the masters... :slightly_smiling_face:

You need to determine whether you've configured the device to have its DHCP server off, and DHCP client on, or not. Try hooking it up to just your laptop and seeing if the laptop gets a DHCP assignment. If it does then the openwrt is still doing DHCP server. If not, then you're probably all set. All you need to do is hook up the NUC to the main network, reboot it, and figure out what IP address it got. (that's the hard part).

However notice that you can connect via ssh using link local ipv6 so if you can figure out its link local ipv6 you can connect even if it's not getting DHCP assignment properly.

To figure out its link local ipv6 you can try plugging your laptop in to it, and then from the laptop (running linux) doing

ping ff02::1%eth0

or replace eth0 with whatever the name of your ethernet device is on the laptop. you should get a reply from the laptop itself and from the openwrt device.

ping ff02::1%eno1 (that is what I see in the Debian network tool)
ping ff02::1%etho

both return "name or service not known"

when I do i "ip addr show" on Debian 10 laptop I see 1. lo and 2. en01 so that seems to be the right name.

Be careful about zero vs letter oh. Your Ethernet is named eno1 the first three are lower case letters then the number 1

In the IPv6 address ff02 is hex digits so it's a zero

1 Like

I rewrote a fresh flash drive of openwrt and tried the instructions again. I went into another part of luci to turn off a DHCP serving feature. I tried the ping ff command and it worked for a while, maybe about 50 lines then Debian said connection failed and then repeated "cannot assign requested address" in the terminal. Never did I see an ip address.

disconnected the Ethernet cable and reconnected. It is showing results again even though Debian desktop is showing Wired connecting...Then it eventually said wired off and the results in the terminal return to "cannot assign requested address".

I seem to be bumping up against a posting limit on this forum so I will try editing previous messages to keep the hope alive.

I do have keyboard and monitor connected to the nuc. The output of ip address show on the nuc while connected to Debian laptop via Ethernet.
Google Photos

the output from ping command on debian
Google Photos

I got the ip address of the nuc while connected to internet! I can now access luci from phone connected to landlords wifi. Now I need to know what to do to activate and use the wifi card in the nuc.

In Luci - software I clicked update lists and chose to install kmod-ath9k and associated files. After install I rebooted the nuc and there are no new wireless devices showing in the network - interfaces section...the software seems to be installed. Does it need further attention to activate it upon boot? I am unsure how to get the wifi portion working.

The nuc has been restarted more than once since installing kmod-ath9k. Not sure what is required to make the wifi work.

Ok, I installed the items mentioned by mk24 but the "etc" is unknown to me. I had no idea that those items were needed and certainly don't know what "etc" would be. I am currently looking here[[https://www.linux.com/training-tutorials/linux-wireless-networking-short-walk/] for items that might be necessary. I don't find nl80211 and cfg80211 is showing as kmod-cfg80211? Or is that something else? Just wandering around in the dark...

I see that iw-full was installed at some point. That includes iw and can function ok as is? When attempting to install wpad-mesh-wolfssl:

Google Photos

I get this:

Google Photos

...and what is the process for "recompiling openwrt with that build time option set"? Is that likely going to take many hours to understand and accomplish?

May thanks to the Linux experts who have helped me and others. 🙋😊

Debian uses network manager by default it disables the Ethernet after a timeout if it doesn't get an IPv4, even though the IPv6 is working fine...

Show output of ping command

If you have keyboard and monitor on the NUC you can run

ip addr show
1 Like

the ipv6 link local address is the one

however it looks like you've gotten past that part and are now on to the next thing. Once you've got the full set of wifi drivers installed luci should show you a wifi device. if it doesn't it's probably because some additional kernel modules are needed, or maybe a reboot?

1 Like

There are no wifi packages installed by default-- you need the whole stack cfg80211, nl80211, and userspace functions iw, wpad, wireless-regdb etc.


The complete list: kmod-ath9k kmod-cfg80211 kmod-mac80211 wpad-mesh-wolfssl iw iwinfo wireless-regdb

Most of these have dependencies which should automatically install.

1 Like

On top of the above, there is also a very strong chance that ATH9K_SUPPORT_PCOEM is required - which would entail recompiling OpenWrt with that build-time option set.

1 Like

That's a really good point. I think that even with just ath9k installed, if OEM card support is not built in, an EEPROM error will be logged during boot and the driver will not start.

Ideally the x86 releases should be compiled with that flag set, since a pluggable PCIe card is the likely type of hardware an x86 would use.

Not only that but why not make openwrt as user friendly as every router software folks buy as part of the device? Activate any and all wifi and Ethernet ports with some default configuration that allows folks to get connected and configure the device. It already has a default username and password (of nothing) so take this user friendliness a step further. Thank you.

The philosophy even with x86 is to keep the distribution minimal and add packages later. Having every wifi driver like a desktop distribution does is not in line with that. Most OpenWrt x86 deployments are main routers in a purely wired role. Also there is a security problem with bringing up wifi on first boot since there's no practical way to assign unit-specific default encryption keys.

When there is only one Ethernet port obviously you can't start it up and use as a router right away without some particular configuration. If two Ethernet ports are found it will configure one as LAN and one as WAN.

1 Like

For 1 Ethernet port, you can do either (1) Configure the single Ethernet port to 2 802.1q VLAN ports, however you'll need a switch that support VLANs. Or (2) Get an USB to Ethernet controller.