Wish to use 2013 Intel NUC with i3 processor and dead SSD as access point


The SSD died so I bought this wifi card hoping I could use the NUC to provide better wifi in my living space. I've put a bit of time into trying to get openwrt, opnsense, and alpine linux to make a wifi access point out of the 2013 Intel NUC.

Is there a simple way to make this NUC behave as an access point? I am not a software engineer or networking genius. The wifi from the landlord downstairs is too weak to function well so they provided the ethernet connection. I feel that buying a wifi router should not be necessary just for my own personal use. Low phone signal up here too means that calls are generally through wifi from the phone and this is also very problematic due to low signal.

Typically, routers will provide some kind of default ssid and password that would allow the user to get online and configure the unit. It seems that none of these operating systems I've tried do that. But this wifi card is working readily with all the linux and bsd operating systems I have tried on it.

Welcoming advice. :slight_smile:

Thank you.

What exactly is the model of the NUC?
Without the model of the NUC I can't even say if it even has an ethernet port ( https://ark.intel.com/content/www/us/en/ark/products/71274/intel-nuc-kit-dc3217by.html for example lacks ethernet port.)

OpenWRT (and others designed to convert an x86 pc into a router) kinda assume 2 ethernet ports, one being the WAN and the other one the LAN.
If you have 1 single ethernet port OpenWRT will assume that's the LAN port (because you are supposed to configure it and with 1 single ethernet port if you have it set as WAN you just can't configure it; wireless is disabled by default).

I think (I can be wrong, it's been some time since i last tried to use one) that the official OpenWRT x86 image lacks the wireless drivers. If this is the case then well you have a little problem. With 1 single ethernet port OpenWRT will set it as LAN, yet to get the wireless working you need to download and you can't cause you don't have a WAN...
Only way I see it is to self-build an OpenWRT image with the right drivers (you will kinda have to boot the NUC from a Linux live usb stick and figure out what drivers are being used), configure it to have OpenWRT acting as an AP, after that connect by wireless and change the single ethernet port from acting as LAN to act as WAN.

Such setup with 1 single ethernet port (that has to act as WAN) and 1 wifi card well is not optimal. Debuging problems is not that easy...

I know my post might look unfriendly but:

  • without the model of the NUC I don't know if the NUC has an ethernet port (if it doesn't have then an usb to lan adapter is needed)
  • even knowing the model won't be enough for me to say if you need or not some particular driver for your NUC to work properly (this is why I wrote the part about booting from an Linux usb live stick to figure out the drivers needed)

It should be possible to boot the NUC, plug into it with a laptop, config it's LAN as a static IP in the LAN zone from the router, turn off the DHCP server and then plug it into the main LAN to continue downloading wifi packages etc


Thank you. It is this NUC

I was considering that. But a regular Ethernet cable would not work for this? A crossover cable would be required?

Modern equipment does not require crossover cables-- the hardware will detect a crossover situation and automatically reverse Tx and Rx functions within the chip.

To configure, connect the NUC direct to a laptop with a regular cable. Don't connect it to any other network at first. Laptop should automatically obtain a 192.168.1.X IP and the OpenWrt install is at

That is an ath9k card, so after getting a wired connection to the Internet, you will need to install kmod-ath9k and the rest of the wifi 80211 stack.


OK. I tried a freshly written openwrt IMG to flash drive. The Debian 10 laptop is connected via Ethernet to the nuc. The laptop is on and running. I booted from the fresh flash drive. Debian 10 on the laptop says cable unplugged. I tried starting the nuc / flash drive first then starting the Debian laptop; still "cable unplugged".

no keystrokes have been made on the fresh openwrt instance. Just bootEd it up and let it alone.

Try unplugging and replugging the cable. Try a different cable

1 Like

Do you see OpenWrt boot up fully? If you do hit the enter key on an attached keyboard you should get a shell prompt on the local HDMI display.

On that vintage of Intel machine I think the Ethernet card will be an e1000e, and its driver should be in the default builds.

1 Like

Ok. The different Ethernet cable made the difference. I can access openwrt configuration com Debian laptop. Looking around the interface...

Yes, e1000e shows on the nuc.

Don't try to use a two pair Ethernet cable-- often supplied with ADSL modems and other 10/100 hardware-- to link gigabit ports. The cable must be 4 pair.


Ok. Thank you. I have access to the web based configuration from the Debian laptop connected via Ethernet. How would I activate the wifi capabilities? This machine has one Ethernet port and the wifi card. The Ethernet connection is being used for the configuraction - not internet connected.

add new interface dialog doesn't seem to show anything about wlan or wifi.

Great info, I didn't know this.

First set up the network so it is a LAN device -- go to Network-Interfaces and edit the LAN. Change it to DHCP Client and turn off the DHCP server. Then you can plug the Ethernet port into your home network instead of direct to the PC so OpenWrt will have Internet access. Also then connect the laptop to the home network and log in to OpenwWrt again at its new IP that is part of the home network. (you will need to discover this IP by logging into the home main router and examine the DHCP assignments, or if the home router does local DNS properly you can access openwrt.lan.)

However because of LuCIs reversion feature, to change the LAN IP requires a confirmation. After clicking Save and Apply, don't touch anything but wait for about 2 minutes for a "Changes Reverted" to pop up on your browser. Then click Apply Unchecked, and only then is the new setting permanent and you can move the cable.

Ok. I am going to read your instructions slowly and carefully to try to do what you have instructed...

on the Interfaces >> LAN General Settings in the Protocol pull down I will change it from Static address to DHCP client. Then I will confirm "Really switch protocol". I clicked restart and then save and apply.

Now I am going to try to figure out what the new address is...