Wireless weirdness 'devices not active'

This is a common error message, but so far none of the solutions in various threads did help. The problem is resolved normally by rebooting, but this does not persist and the problems reoccur few hours/days again.

The problem with wireless is in several areas:

  1. the 5 GHz does not show up on the list of available networks
  2. the guest wifi is visible, but will not receive an IP address (hanging indefinitely at "obtaining IP address")
  3. Luci shows the guest interface as not present
  4. Luci shows all wireless devices as not active and the associated wlans as not associated

I am using OpenWrt 21.02.0-rc1 on an AVM 4040 since yesterday, but the problem has been before with 19.07 already

Best illustrated in this screenshot showing the Luci page plus the KDE network widget simultaneously.

This is what the log says

Wed May 19 15:46:36 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED dc:53:60:36:30:d5
Wed May 19 15:46:39 2021 daemon.info hostapd: wlan0-1: STA dc:53:60:36:30:d5 IEEE 802.11: authenticated
Wed May 19 15:46:39 2021 daemon.info hostapd: wlan0-1: STA dc:53:60:36:30:d5 IEEE 802.11: associated (aid 1)
Wed May 19 15:46:39 2021 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED dc:53:60:36:30:d5
Wed May 19 15:46:39 2021 daemon.info hostapd: wlan0-1: STA dc:53:60:36:30:d5 WPA: pairwise key handshake completed (RSN)
Wed May 19 15:46:39 2021 daemon.warn dnsmasq-dhcp[3531]: DHCP packet received on wlan0-1 which has no address
Wed May 19 15:46:45 2021 daemon.warn dnsmasq-dhcp[3531]: DHCP packet received on wlan0-1 which has no address
Wed May 19 15:46:54 2021 daemon.warn dnsmasq-dhcp[3531]: DHCP packet received on wlan0-1 which has no address
Wed May 19 15:47:01 2021 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED dc:53:60:36:30:d5
Wed May 19 15:47:03 2021 daemon.info hostapd: wlan0: STA dc:53:60:36:30:d5 IEEE 802.11: authenticated

wlan0-1 is my guest wlan, wlan0 is the 2,4 wifi net. The 5 GHz wifi does not show up in the list, though it used to be the priority for the laptop.

**/etc/config/network**

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'pppoe'
        option password 'SECRET'
        option ipv6 '0'
        option username 'REDACTED'
        option delegate '0'

config interface 'guest'
        option proto 'static'
        option delegate '0'
        option force_link '0'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
/etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT40'
        option legacy_rates '0'
        option country 'FR'
        option channel 'auto'
        option txpower '18'
        option disabled '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'
        option channel '124'
        option legacy_rates '0'
        option txpower '17'
        option country 'FR'
        option disabled '0'

config wifi-iface 'wifinet0'
        option ssid 'Pluto_2'
        option device 'radio0'
        option mode 'ap'
        option key 'TOPSECRET'
        option encryption 'psk2'
        option disassoc_low_ack '0'
        option network 'lan'

config wifi-iface 'wifinet1'
        option ssid 'Pluto_5'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option key 'TOPSECRET'
        option network 'lan'

config wifi-iface 'wifinet2'
        option network 'guest'
        option ssid 'Pluto_guest'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option isolate '1'
        option key 'NOT_TOP_BUT_SECRET'
        option disabled '0'

Channel 124 you will have to wait for DFS before the 5 GHz comes up. Check the log for errors related to bringing wifi up.

iw dev should show all your APs. If they have a channel and an SSID listed, they are fully active.

I always make the guest network a bridge even if it has only one AP. Do you have a DHCP server enabled on guest? ip link show should show the guest network as up and having an IP. DHCP packet received... means that the wifi connection is operational but dnsmasq was unable to fill the request.

1 Like

I followed the wiki on setting up the guest wifi. It might be a good idea though to set it up as a bridge. If I only knew how.....

The router was running for hours today, flawlessly, but causing the wifi issues. No idea what triggers it.

Just add option type bridge like lan has.

Thank you, did it accordingly. Let's see whether this makes a change.

However, the above picture shows a discrepancy between information shown in Luci and reality. Apparently Luci considers all radio networks down while they aren't. Anybody with similar experience, or explanation?

Made the changes

Nobody?

The change suggested by @mk24 did not change the situation. Again in the afternoon, wifi broke down, i.e. devices were disconnected, Luci reports devices as not available.
Just saw that @trendy always asks for certain outputs in case of wifi trouble. The network and wireless config files are in the initial post, here comes the other information:

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option confdir '/tmp/dnsmasq.d'
        list server '127.0.0.53#53'
        option noresolv '1'
        option sequential_ip '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option leasetime '12h'
        option interface 'guest'
        option limit '10'
        option start '1'

config dhcp 'Fon'
        option leasetime '12h'
        option interface 'Fon'
        option start '2'
        option limit '3'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list device 'br-lan'
        option family 'ipv4'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        option enabled '0'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
        option family 'ipv4'

config include
        option path '/etc/firewall.user'

config zone
        option name 'guest'
        option forward 'REJECT'
        option output 'ACCEPT'
        option input 'REJECT'
        option family 'ipv4'
        list network 'guest'

config rule
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '53'
        option name 'Guest DNS'
        option family 'ipv4'
        option src 'guest'

config rule
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '67-68'
        option name 'Guest DHCP'
        option family 'ipv4'
        option src 'guest'

config forwarding
        option dest 'wan'
        option src 'guest'

config zone
        option name 'Fon'
        option forward 'REJECT'
        option output 'ACCEPT'
        option family 'ipv4'
        option input 'ACCEPT'
        list network 'Fon'

config forwarding
        option dest 'wan'
        option src 'Fon'

config rule
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '67'
        option name 'Fon DHCP'
        option family 'ipv4'
        option src 'Fon'

config forwarding
        option dest 'Fon'
        option src 'lan'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
12: eth0.4@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.3.1/24 brd 192.168.3.255 scope global eth0.4
       valid_lft forever preferred_lft forever
14: br-guest: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.0.1/24 brd 192.168.0.255 scope global br-guest
       valid_lft forever preferred_lft forever
17: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    inet 93.204.0.54 peer 62.155.246.54/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 62.155.246.54 dev pppoe-wan 
62.155.246.54 dev pppoe-wan scope link  src 93.204.0.54 
192.168.0.0/24 dev br-guest scope link  src 192.168.0.1 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1 
local 93.204.0.54 dev pppoe-wan table local scope host  src 93.204.0.54 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.0.0 dev br-guest table local scope link  src 192.168.0.1 
local 192.168.0.1 dev br-guest table local scope host  src 192.168.0.1 
broadcast 192.168.0.255 dev br-guest table local scope link  src 192.168.0.1 
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.1 
local 192.168.1.1 dev br-lan table local scope host  src 192.168.1.1 
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.1 
0:      from all lookup local 
32766:  from all lookup main 
32767:  from all lookup default 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f2b0:14ff:fee2:27db/64 scope link 
       valid_lft forever preferred_lft forever
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f2b0:14ff:fee2:27da/64 scope link 
       valid_lft forever preferred_lft forever
12: eth0.4@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f2b0:14ff:fee2:27da/64 scope link 
       valid_lft forever preferred_lft forever
14: br-guest: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f0b0:14ff:fee2:27dc/64 scope link 
       valid_lft forever preferred_lft forever
15: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f2b0:14ff:fee2:27dd/64 scope link 
       valid_lft forever preferred_lft forever
16: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f2b0:14ff:fee2:27dc/64 scope link 
       valid_lft forever preferred_lft forever
17: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 fe80::28a9:559e:3a87:70fb/128 scope link 
       valid_lft forever preferred_lft forever
18: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::f0b0:14ff:fee2:27dc/64 scope link 
       valid_lft forever preferred_lft forever
unreachable fd89:dedc:b1bc::/48 dev lo  metric 2147483647 
fe80::28a9:559e:3a87:70fb dev pppoe-wan  metric 256 
fe80::2a8a:1cff:fee3:c830 dev pppoe-wan  metric 1 
fe80::/64 dev eth0.4  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth1  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/64 dev br-guest  metric 256 
fe80::/64 dev wlan0-1  metric 256 
fe80::/64 dev wlan1  metric 256 
local ::1 dev lo table local  metric 0 
anycast fe80:: dev eth0.4 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev eth1 table local  metric 0 
anycast fe80:: dev wlan0-1 table local  metric 0 
anycast fe80:: dev br-guest table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
anycast fe80:: dev wlan1 table local  metric 0 
local fe80::28a9:559e:3a87:70fb dev pppoe-wan table local  metric 0 
local fe80::f0b0:14ff:fee2:27dc dev wlan0-1 table local  metric 0 
local fe80::f0b0:14ff:fee2:27dc dev br-guest table local  metric 0 
local fe80::f2b0:14ff:fee2:27da dev eth0.4 table local  metric 0 
local fe80::f2b0:14ff:fee2:27da dev br-lan table local  metric 0 
local fe80::f2b0:14ff:fee2:27db dev eth1 table local  metric 0 
local fe80::f2b0:14ff:fee2:27dc dev wlan0 table local  metric 0 
local fe80::f2b0:14ff:fee2:27dd dev wlan1 table local  metric 0 
multicast ff00::/8 dev eth0.4 table local  metric 256 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev eth1 table local  metric 256 
multicast ff00::/8 dev pppoe-wan table local  metric 256 
multicast ff00::/8 dev wlan0 table local  metric 256 
multicast ff00::/8 dev br-guest table local  metric 256 
multicast ff00::/8 dev wlan0-1 table local  metric 256 
multicast ff00::/8 dev wlan1 table local  metric 256 
0:      from all lookup local 
32766:  from all lookup main 
4200000001:     from all iif lo lookup unspec 12
4200000011:     from all iif br-lan lookup unspec 12
4200000012:     from all iif eth0.4 lookup unspec 12
4200000014:     from all iif br-guest lookup unspec 12
4200000017:     from all iif pppoe-wan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Apr 18 12:06 /etc/resolv.conf -> /tmp/resolv.conf
lrwxrwxrwx    1 root     root            35 May 20 18:50 /tmp/resolv.conf -> /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            63 May 20 18:50 /tmp/resolv.conf.d/resolv.conf.auto
-rw-r--r--    1 root     root            47 May 20 18:50 /tmp/resolv.conf.ppp

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            63 May 20 18:50 resolv.conf.auto
==> /etc/resolv.conf <==
# Interface wan
nameserver 217.0.43.113
nameserver 217.0.43.97

==> /tmp/resolv.conf <==
# Interface wan
nameserver 217.0.43.113
nameserver 217.0.43.97

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.ppp <==
nameserver 217.0.43.113
nameserver 217.0.43.97

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 217.0.43.113
nameserver 217.0.43.97

I hope somebody can advise.

Cheers
Oscar

I think that it's best to select the channel manually. Also see if the txpower setting is stressing the device and needs to be lower. Finally check the power supply, if it is not delivering enough power it might affect the device.

I guess that neither would be responsible for the obvious discrepancy shown in the image of my initial post, i.e. "Device inactive" in Luci while at the same time the wifi is visible to clients should be an OpenWRT issue, I believe.

I had the same situation with my laptop just 1 meter away from the router, and there are just a few other networks around here.

Or, it might be a hardware issue, though. Just a guess, because it does not seem to be something other people experience.

In any case, a reboot fixes it until the next day.

At this moment my mobile phone is connected, while Luci shows "device inactive" for both radios. For the networks, it says "wireless is not associated". The mobile phone though enjoys internet access (gsm is blocked, so it has to be through wifi).

The iwinifo command is the OpenWrt-specific middleware that LuCI uses to collect wifi status information.

iwinfo with no parameters should return something like this for an AP interface that is up with a station connected:

wlan1     ESSID: "<redacted>"
          Access Point: 14:CC:20:<redacted>
          Mode: Master  Channel: 157 (5.785 GHz)
          Tx-Power: 19 dBm  Link Quality: 55/70
          Signal: -55 dBm  Noise: -95 dBm
          Bit Rate: 6.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11an
          Hardware: 168C:0033 168C:A120 [Atheros AR9580]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

iwinfo wlan1 assoclist will print details of the stations connected to that AP. Much more detail can be found with iw, but I think that iwinfo is the only program that LuCI calls.

1 Like

Sorry for nagging with this, but it keeps on being an annoying trouble.
For better illustration 2 images, taken almost simultaneously:

While the interface section shows active wireless (guest is wifi-only), the wireless section says the radios are all down. The latter is not true but for the 5 GHz wifi. The 2.4 GHz wifis continue working for a while, but break down one or two hours later as well.

I hope one of the experts comes across this. I have no clue what else to do.

A reboot will fix it for some hours, and then the hazzle starts all over again.

My first post with nil suggestions. The problem is reproducible, it happens every day, a reboot fixes it until the next day.

If nobody experiences something similar, that would point to a hardware issue.

check the device's time

My router had the same problem after a power failure
Then I found that the time was wrong. After I adjusted the time correctly, it became normal

Here's what worked for me on two of my devices. I was facing the same issue.

For the Radio which is showing as not active Goto
Network-->Wireless-->Add-->
Under General Setup --> Wireless Network is enables the default value will be disbale as shown in the image.

Disable that and Luci will apply configuration changes.

Again go the same place and now click enable. It will associate with the Radio.

1 Like

I am also having this "Device not active" issue.
I tried doing what you suggest and disabling/enabling the wireless, but in the Device configuration, if I press "Disable", Save & apply changes, then go there again, it still shows "Wireless network is enabled".

I checked the time and set the time zone to the correct setting. Time displays correctly, but the Wireless Overview still shows "MediaTek MT7622 802.11bgn Device is not active". I am using a Linksys E8450 with SNAPSHOT r21775-c83dbcdf8f of OpenWRT. Wireless was working fine before the update, which I did in an attempt to resolve another issue. Since then, I have reset the device to defaults, as it was suspected that carrying over the configurations during upgrade may have broken something.

So, with a default install of this version of OpenWRT, I have the "Device is not active" issue.

Well, for me, it helped to install the version of OpenWRT from the Wiki, which is 22.03.3 as of this writing. I installed that without keeping configurations and wireless worked again.

Did you check what's relevant to WiFi, the Country Setting?

  • Can you sysupgrade to a stable version?
  • Is there a reason you're using a SNAPSHOT?