Wireless-Weak Security in iOS

I’m seeing always in iOS devices weak security to connected OpenWrt wireless.
See the attached screenshot.
In OpenWrt under wireless security cipher is set to auto with WPA2 strong security
I have tried to force AES, but configuration is not saving and rolling back after 90s
OpenWrt installed device is DIR-2660
Where is the problem trying to figure out is OpenWrt or iOS 15 with latest version update.

If possible make the change from a wired device or change the configuration file via ssh

This setting is impossible to do through a wifi connection if that is what you try to do.

OpenWRT will revert settings because you loose connection with the device. To establish wifi connection you need to set CCMP mode, restart the wifi module and then delete the old wifi network in iOS and make a complete new wifi connection.

But have you tried wpa3 instead of wpa2?
iOS has if I remember right had wpa3 support since iOS13.

You may be able to fix this issue by using one of these options:

  • click "apply unchecked" instead of just simply "apply" -- this will not roll back.
  • use a wired computer to make the change
  • use the command line to change your encryption mode.
    (the latter two were also recommended by @Doppel-D )

Just apply unchecked.