Wireless trunking

Dears , I Need help to accomplish my goal .. i have 2 litebeam AC connected to each other via wifi link , "AP type is not WDS . Should i use WDS ?"
On router A , its ISP router . have WAN & 4 LANS ..

Then there is POE Switch with
vlan101 for 192.168.14.0/24
vlan102 192.168.1.0/24

one cable share two vlan go to litebeam AC

Its same concept for router B . my topology described in the picture i attached .

My Goal to share Router A network ON Router B & versa

My Q's :

  • Is that possible ?
  • since there is one ether port in litebeam with name eth0 . should i use eth.101 & eth102 for two vlans ?
  • i have try to do gretap tunnel as i read here:
    Trunking over wireless?
    but when i made only the tunnels as below :
    On Litebeam AC which belong to router A I have :

config interface 'lnk'
option proto 'gretap'
option ipaddr '192.168.1.100'
option peeraddr '192.168.1.110'
option force_link '1'

On Litebeam AC which belong to router B I have :

config interface 'lnk'
option proto 'gretap'
option ipaddr '192.168.1.110'
option peeraddr '192.168.1.100'
option force_link '1'

But when i apply this config , both router stop response to ping , is that normal ?

  • how to define gretap network 192.168.14.0 on Litebeam AC which belong to router A ? how make bridge between gretap network with vlan101 ?

  • i think to get 192.168.1.0 network on Litebeam AC which belong to router B , only i need is bridge wwan with vlan102 , right ?

Current Config :
Litebeam AC ROUTER A :
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdaa:4c40:2a38::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.100'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
list dns '8.8.8.8'

config interface 'tunA'
option proto 'gretap'
option peeraddr '192.168.1.110'
option ipaddr '192.168.1.100'

config interface 'tunAA'
option proto 'static'
option ifname '@tunA'
option ipaddr '192.168.14.253'
option netmask '255.255.255.0'

Thanks for your help

For only two VLANs, using a separate SSID for each and WDS is perhaps the simplest approach

Thanks for reply ,

If i understand correctly , you mean to establish AP + STA on both litebeam devices right?
I have tried that but its fail because STA on first device depend on AP in other device ,
vice versa . right ?

192.168.1.0/24 on first device
192.168.14.0/24 on the second one

Set for WDS, not “plain” AP, as I recall, on just one of the two. As it is a bridge, adjust your subnet appropriately.

https://openwrt.org/docs/guide-user/network/wifi/atheroswds

OK Done, but how to get dhcp access for network on STA Device??

I think you are saying you have two buildings, each one having its own ISP connection and local network, and you want to link the two networks so you can share files and printers as through a LAN.

This would usually be done by setting up a VPN client in one building and a server in the other, and making the link through the Internet, unless you need a very high speed link.

1 Like

Yes , exactly .. but my goal is to get dhcp access from network on another building .. as building A & Building B .. A get dhcp address from B network & vice versa

As you could read in my post, I am successfully trunking several networks over a single wireless connection. I would like to help, but I could not figure out your current setup and what you are trying to accomplish, sorry.

However, I saw that you are using the LAN's IP addresses for the GRE tunnel, while I am using a specific range for the link.

1 Like

I can see you are using different IP sub-net for GRE tunnel .
But how those IP reach each other between AP-STA . make route? ,,

My setup described above , my only concern how to config that only on both litebeam devices :S

Litebeam A : work as AP to share his lan eth0 : 192.168.1.0/24 to Litebeam B . Its work OK .
My goal : let Litebeam A have vlan for 192,168,14.0 network that on Litebeam A

Thank for help :slight_smile:

In my setup, the "main router" has a network for the LAN devices, a network for the IOT devices, a guest network, ... and a specific network just for the "wireless extender". Then I create a GRE tunnel inside that network, and then I bridge different VLANs from that tunnel with the other networks.

1 Like

Can you share your setup config ? If you don't mind or if you can reach it ..

So it's will not work if I use Lan IPs for gre tunnel ?
Thanks

You can use the LAN's IP for GRE tunnel, and then use the tunnel to extend the other networks; but I wanted to tunnel all networks. I'm not sure my config files are going to be useful, but here you are (I tried to clean them up a bit):

/etc/config/network:

config interface 'loopback'
[...]

config globals 'globals'
[...]

config interface 'wan'
[...]

config interface 'wan6'
[...]

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ifname 'eth0 @lnk0.1'
	option ipaddr '192.168.1.254'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint 'fff1'

config interface 'ext'
	option type 'bridge'
	option proto 'static'
	option ifname '@lnk0.9'
	option ipaddr '192.168.0.254'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6hint 'fff0'

config interface 'kid'
	option type 'bridge'
	option proto 'static'
	option ifname '@lnk0.5'
	option ipaddr '192.168.5.254'
	option netmask '255.255.255.0'
	option ipv6 '0'

config interface 'iot'
	option type 'bridge'
	option proto 'static'
	option ifname '@lnk0.4'
	option ipaddr '192.168.4.254'
	option netmask '255.255.255.0'
	option ipv6 '0'

config interface 'lnk0'
	option proto 'gretap'
	option tunlink 'wds0'
	option ipaddr '192.168.250.1'
	option peeraddr '192.168.250.2'
	option force_link '1'
	option mtu '2048'
	option ipv6 '0'

config interface 'wds0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.250.1'
	option netmask '255.255.255.240'
	option force_link '1'
	option mtu '2048'
	option ipv6 '0'

config device
	option name 'wlan_wds0'
	option mtu '2048'

config switch
[...]
1 Like

I've always wondered about that notation. When is the @ required and what does it mean?

(I've generally just used bat0.1234 or the like)

Sometimes, OpenWrt creates interface names that do not mach the name specified at "/etc/config/network". For example, my "lnk0" interface will be seen as "gre4t-lnk0" from "ifconfig" or "ip ...". In those cases, you can use the "@" symbol to refer to "the real interface name created by".

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.