Wireless Radio LEDs

Hi all, RT-88u here, I have configured my LED's as part of LUCI to disable them, however I noticed it doesn't have an option to disable the LEDs for the wireless radios, I know that if I disable the radios they will turn off but that defeats the reason for having a wireless router.

also if I list my LED's in

ls /sys/class/leds/
red:wan      white:lan    white:power  white:usb2   white:usb3   white:wps

That's all I have, has anyone been able to come up with a way to disable radio LEDs while still keeping the radio active?

Post the contents of /etc/config/system -- the LED configuration should be there.

The WLAN LEDs unfortunately can't be controlled in OpenWrt. No GPIO found for it and looking at the source code from ASUS showed a method call but no source for the method itself (if I remember correct).


1 Like

I've already mentioned this on the device page.

@zamarax to disable the wireless LEDs, you can run these commands:

nvram unset 0:ledbh9 unset 1:ledbh9 && nvram commit
rm /etc/init.d/nvram

The first command unsets the variables for the wireless LEDs' behaviour.
The second deletes the /etc/init.d/nvram file so the variables won't be set again.


Btw, if you feel the question is answered (by @arinc9 in this case) then it helps if you mark this thread as solved. That way this topic will close 10 days after the last post.

1 Like

So I tried that and it unfortunately put my device is a reboot loop.

I tried powering it off for a bit and then seeing and same thing, WAN / LAN would come up for about 8 seconds and then reboot.

I've since done a factory reset and restored an older config.

I just tried it on my RT-AC88U, both wi-fi radios are up and LEDs are down. 22.03.3 is broken, revert to 22.03.2 if you tried that.

Fair enough, I downgraded and now it did work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.