Wireless is not associated

Hi guys,

I want to set up my Raspberry Pi 3B+ as a travel router with Openwrt. I followed this guide:

The point where I'm stuck is "Setting up USB Wifi Adapter".

I have an TP-Link TL-WN823N Wifi Stick, which uses a Realtek rtl8192eu Nic, according to this page:

In the Luci GUI, I installed all rtl8192eu drivers and also the rtl8xxxu drivers.

After executing the command "ifconfig wlan1 up", I get the error message "ifconfig: SIOCGIFFLAGS: No such device"

This command should pass without any feedback or error message.

I paste the content of the /etc/config/network and the /etc/config/wireless in the pastebin
and also parts of the "logread" output.

The interface name for radio1 should be phy0-ap0, but this device doesn't start.

Can you help me with this?

The Wifi of the USB Adapter is not working, I do not see it on any device (mobile phone, tablet, etc.).

Thank you for your help.

If you need more information, please let me know.


Get a non-RTL based wifi stick, or try using the RTL stick as wireless client instead.

Ok. Do you have any recommendations?

So after some research, the Panda Pau sticks seem to be a possible choice. Do you have any experience with these sticks?

USB Wi-Fi that work in OpenWrt. Please add to list might be of use to you.

1 Like

Think I'm going to order the Panda. Several other sticks are not available in my country.

Or can I use this stick as well?

It bears a Ralink RT5370 Chip, but I don't know, if it will work in AP mode...

I would prefer it over the Panda, since it is cheaper and readily available.

We can't tell you for sure.
That is is topic of the link @frollic provided: confirmed working dongles.
You are welcome to take a chance, like others have done for you like @fakemanhk, @KSofen, I and others and, then, provide your feedback. To help the community.

I have the Panda and I got it to work.

Maybe it is confirmed to work in a different thread but those little, flush-mount, dongles are not the best choice for range.

Yes it should work in AP mode but it's only 802.11n 2.4GHz one.
If you want 802.11ac you can consider this one.

1 Like

There's also plenty of working sticks listed on the GitHub page, linked to earlier.

1 Like

@LilRedDog: I ordered the Anadol Gold with the Ralink RT5370 Chip and it will be delivered tomorrow.
I will test it then and report back, if and how good the stick performs.

Can you tell me something about the Panda, how is the Wifi speed absolute and relative in comparison to the maximum download and upload rates? And what is your overall feedback to the Panda?

Range is not so important for me as the Pi is intended to be a travel router to work in a hotel room. So all my devices are very close to the router.

@fakemanhk: Thank you for the information. As mentioned above, I already ordered the one with the Ralink chip. 802.11n would be fine. As I said, it's only for a travel router and not for daily use, so the bottleneck will always be the internet speed of the hotel and not the stick.
If I am not satisfied with the performance of this cheap stick, I will definitely come back to the Panda, thank you.

@frollic: As mentioned above, I will give the Anadol stick a try and will report back. If the performance is acceptable, I will stick with it. If not, depending on @LilRedDogs feedback, I will go with the Panda or with another stick from the list.

Thank you guys for your help!

If you are not caring about WiFi speed, you should get this and call it a day.

It will work, but it’s slow. The Ralink chips run hot and my first one burned out in a few months usage. I bought a Canakit version and it worked in station mode and the blue light came on. In AP mode I got lots of errors in the log and very slow speed. In station mode, it was reliable, but just way too slow to use and I abandoned it for the Panda.

@fakemanhk That's where I come from. :smiley:

I have a GL-AR750, but the CPU Power is so low (1 core, 650 MHz), that not even Adguard Home can run on it. Furthermore, this router doesn't get the latest firmware and as a consequence, DoH is not available via the GUI. This router model is pretty outdated and I thought about purchasing new hardware. When I compared the CPU of the top Travel router from GL.inet, I quickly came to the point, that using my existing Pi 3B+ would be the best and cheapest option.

@KSofen Thank you for your feedback.
This Pi is not intended to run 24/7, only when I'm away, which is not very often at the moment.
How satisfied are you with the performance of the Panda?

The Panda is working fine for the purpose, but the nature of the RP4 itself is the limiting factor. I'm like you. I wanted a small dongle to keep things small and portable. All the small dongles were unusably slow even for a travel router and they had to be the client not the access point in the setup. Presently, my OpenWrt travel router boot microSD card is setup to use the built-in as the client, and the Panda as the AP. I rolled back the firmware to 22.03.6 because the current release flooded my log with errors that I could not correct even with everyone on the forum helping. The speed is limited to 100 mbps because I route everything through VPN. Captive portals will frustrate you using it as a travel router. I'm still trying to figure out a workaround for that.

For those of you in the USA, this is the Amazon link:

GL.iNet GL-MT300N-V2(Mango) Portable Mini Travel Wireless Pocket VPN WiFi Router - Access Point/Extender/WDS | OpenWrt | 2 x Ethernet Ports | OpenVPN/Wireguard VPN | USB 2.0 | 128MB RAM

that price's a joke though, when the Belkin RT1800 is sold for $29 too, on US eBay.
but sure, if you need the portability ...

The configuration is easy on this device. There's a video on the Amazon page. It has a wrapper around OpenWrt that simplifies things instead of Luci.

Ok and do you have experience with dongles with bigger antennas? And do you think that the PI is the problem and if yes, could this be overcome by using another SBC/device with x86 architecture?

100 Mbps would be fine, I don't expect to get speeds like this in any hotel I will visit in the near future.

The thing with the captive portals doesn't sound very good. For the GL.inet router I was able to connect to a wifi with captive portal. I had to deactivate DNS rebind protection and then it worked. For Openwrt I don't know too much about connecting to a captive portal. I assume you have the travelmate package installed, right? And you still have issues?
I hope my router will have less issues. :smiley:

The travelmate package does not work when installed as instructed on the RP4. Not ready for primetime and I've never got it to work. The OpenVPN app on the iPhone does handle Captive Portals, but the Pi Travel Router can't get internet when it hits a captive portal. I'm trying to figure out how the Roku does it so well. When you log in to a connection on the captive portal, it gives you a link to go to on your phone to complete the captive portal screen and then everything works. If I could make the RP4 do that everything would be perfect.

Take a look at this video for another method to try.

Raspberry Pi Travel Router